2

I just installed Ubuntu 20.04 and want to use the GNOME Flashback session, as I'm used to the old GNOME look and don't like the new one. I also installed the Radiance theme because I like it more than default ones installed with Ubuntu. I even did some minor tweaks to theme's CSS files to get rid of a few things that annoyed me (e.g. the very ugly "overshoot" effect when scrolling past top or bottom of a window) and everything is working well.

However, there's one thing I don't know how to change. The default text color for desktop icon labels is too dark and is hardly visible on the default background:
here is the screenshot

I don't know how to change it. From what I could find on the Net, people advise to change the color for .nautilus-desktop.nautilus-canvas-item CSS element. I found this element in gtk-3.0/apps/nautilus.css and gtk-3.20/apps/nautilus.css files and changed both, however it didn't work - the color didn't change.

Please tell me what should I change in the CSS files to change this color?

  • This will end with installing MATE DE at the end, I think. GNOME FlashBack degrading too fast. Desktop is controlled by some extension nowadays with limited functionality. – N0rbert Jun 1 '20 at 8:04
  • 1
    I was (and currently still am) using Ubuntu MATE 18.04 for a while, because of my old computer being a 32 bit one, so I cannot install the main Ubuntu variant, which is now 64 bit only. However, I found out that some things in the DE were failing and I had to disable them - probably MATE DE is not tested as well as GNOME. On a new computer I just bought I would like to return to proper GNOME. The color in question definitely CAN be changed, as default themes (eg. Yaru) are doing this. It's only a question how? Wish there was some detailed documentation on creating themes... – raj Jun 1 '20 at 10:07
1

gf-icon label { color: red; } should change color to red.

  • 1
    BIG THANKS! It works! However, I found out that "gf-icon" does never occur in the original theme .css files. But default Ubuntu themes somehow set this color to white, while any other themes don't. Even if i make an exact copy of original theme's files and give it another name, it doesn't set this color and it still remains at dark default as in my example. I also found another issue related to exactly the same situation (default vs non-default themes), which I'm about to post soon. Could you please look at it as well? – raj Jun 1 '20 at 16:57
  • 1
    gnome-flashback has custom css for some themes - gitlab.gnome.org/GNOME/gnome-flashback/-/tree/master/data/theme. – muktupavels Jun 1 '20 at 17:15
  • Thank you again! Could you please look at this: askubuntu.com/questions/1245851/… ? Looks like a bit similar issue... – raj Jun 1 '20 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.