11

Before, I had problems installing the a200 intel wifi/bluetooth driver which I didn't manage to install properly (I had downloaded it but couldnt use it - I didn't get it running). Then I installed instead blueman, dkms etc and got an internal error message. I de installed all that and the internal error message is also gone, but I still get this message when booting.

In the progress, I also edited via vim that "compress gzip" but that didn't help.

I also had entered rtbth in /etc/modules over vim but I am not sure whether I did that correctly.

Nonetheless, I de installed blueman, blueman manager and dkms but I am still left with that error message shown above, that had not been there before I started to fix my bluetooth problems.

Maybe you can help? (BTW, kernel is 5.4)

14
  • Undo your previous attempts, and do sudo update-initramfs -c -k $(uname -r). Reboot. Report back. – heynnema May 31 '20 at 18:38
  • hey thank you a lot!! the error message is gone now :). only downside is that my bluetooth completely doesnt work anymore, but I will either try that some time again or will just get an usb cable for the speakers i used to connect via bluetooth. – medskillz Jun 1 '20 at 9:00
  • Did you set compress gzip back to default? If not, do so, and redo the update-initramfs command. Also, your edit of /etc/modules with rtbth is probably incorrect, and that's probably why bluetooth doesn't work. What is rtbth? What dkms driver had you tried to install? What bluetooth driver had you tried to install? – heynnema Jun 1 '20 at 12:45
  • ok i put compress back to default (compress=lz4) and bluetooth is working now again. I was actually trying this: askubuntu.com/questions/1231074/… sudo apt install blueman sudo add-apt-repository ppa:blaze/rtbth-dkms sudo apt-get update sudo apt-get install rtbth-dkms sudo vim /etc/modules Comment all and add this line rtbth Reboot and open sudo blueman-manager If still not work, try this sudo rmmod btusb sleep 1 sudo modprobe btusb – medskillz Jun 1 '20 at 15:12
  • So i actually wanted to install this driver from here (for ax 200) intel.de/content/www/de/de/support/articles/000005511/… - when I am in ubuntu under "software & updates" it says that "Intel Corporation:Wi_fi 6 AX200" wasn't working. Thats why I actually started trying to "fix" my bluetooth (and my bt also wasnt working every time I boot, but it appears to be working well now). But ye, I still found it frustrating that that device is apparently not fully working. – medskillz Jun 1 '20 at 15:19
13

From the comments...

  • set back compress=lz4 in /etc/initramfs-tools/initramfs.conf

  • rebuild your ramdisk with sudo update-initramfs -c -k $(uname -r)

  • reboot

Note: Use the sudo update-initramfs -c example, not sudo update-initramfs -u variation.

19
  • 4
    Here, compress=gzip in /etc/initramfs-tools/initramfs.conf fixed it. Thanks for the lead anyway. – Sqerstet Jul 6 '20 at 5:19
  • I have to repeat these steps each time I receive a system update for initramfs. – rationalbeing Jul 16 '20 at 21:36
  • 1
    @user25406 In terminal, type grep -i compress /etc/initramfs-tools/initramfs.conf and if it returns =lz4, then leave it alone. If you have another problem, please start a new question. – heynnema Aug 25 '20 at 13:37
  • 1
    @user25406 Did you do the sudo update-initramfs -c -k $(uname -r) command using the -c option? If Ubuntu boots after you see the message, ignore the message, as it's kind of bogus. – heynnema Aug 25 '20 at 13:59
  • 1
    @user25406 No, type the command exactly as I have it. – heynnema Aug 25 '20 at 14:05
0

Use compress=gzip instead of lz4. That worked for me. Then follow heynnema sudo update-initramfs -c -k $(uname -r). This should work this time.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.