10

From yesterday, openweather extention on the top panel does not show the weather. Its shows "Please wait Loading".

I tried to find the solution. There was a post of creating account on openweather website and use API id. I found that it is a subscription base plan. There was a free plan which allows 60 calls free for weather data.

I thought that the extention is open source. And may be I deleted any package that is required to work the extention so I reinstall the OS. But there is no difference of doing that. enter image description here

What could possibly go wrong any guidance?

  • 1
    Only Ubuntu and official flavors of Ubuntu (ubuntu.com/download/flavours) are on-topic here, refer to askubuntu.com/help/on-topic where you'll find other SE sites where you question will be welcome if you don't want to use a Pop forum. (One advantage of Ubuntu is it's many support options, you opted for Pop OS so take advantage of it's support options, or SE Unix & Linux) – guiverc May 31 at 7:16
  • I am using Ubuntu 18.04.4 LTS and the same issue persists with this OS too. I have sent a bug report to the writer from within the extension page. I would respectfully request that this is not closed as it doesn't just relate to pop-os but to the supported versions of Ubuntu too. If/when I get a reply, I will post a solution. – User24601 May 31 at 7:21
  • @User How long you are having the issue? – Trushar Gavit May 31 at 7:58
  • 1
    I'm having the same issue since yesterday (may 30th). – gccallie May 31 at 9:36
  • 1
    @gccallie I'd recommend you to raise a bug report to the developer too as I have done. More reports to them might help get the issue resolved. – User24601 May 31 at 9:46
16

Found a solution on GitLab from @StephGbzh that just worked for me using 20.04. It is most likely an expired CA certificate:

  1. check that you target the right expired certificate

    openssl x509 -issuer -enddate -noout -in /usr/share/ca-certificates/mozilla/AddTrust_External_Root.crt
    

    which will produce the following:

    issuer=C = SE, O = AddTrust AB, OU = AddTrust External TTP Network, CN = AddTrust External CA Root
    notAfter=May 30 10:48:38 2020 GMT
    
  2. backup

    cp /usr/share/ca-certificates/mozilla/AddTrust_External_Root.crt ~
    
  3. delete

    sudo rm /usr/share/ca-certificates/mozilla/AddTrust_External_Root.crt
    
  4. update the system

    sudo update-ca-certificates
    
  5. restart gnome shell: AltF2, r, Enter
| improve this answer | |
  • 1
    Perfect - That worked for me on 18.04 LTS. Thanks! Could the op mark this one as the solution please to allow others to find it easily. – User24601 May 31 at 14:32
  • 1
    I think it might help to separate out the two instructions at number 2 to take it in two distinct steps which will help newish users: perhaps 2a. to backup the file then 2b to delete it. – User24601 May 31 at 14:41
  • When I ran update-ca-certificates, the deleted "AddTru..." certificate is not downloaded. Will its absence cause any problems ? – AJN May 31 at 16:41
  • 1
    Thanks man. It worked. – Trushar Gavit May 31 at 18:04
4

Another way to fix it without deleting .crt files, or disabling secure http.

In terminal:

Change directory.

cd /etc

Make a backup of this file.

ls -al ca-certificates.conf*
sudo cp ca-certificates.conf ca-certificates.conf.BAK
ls -al ca-certificates.conf*

Edit this file.

sudo pico ca-certificates.conf
change "AddTrust_External_Root.crt" to "!AddTrust_External_Root.crt"

Update certificates.

sudo update-ca-certificates
restart gnome shell with ALT+F2, r, ENTER

Reference: https://gitlab.com/jenslody/gnome-shell-extension-openweather/-/issues/272

| improve this answer | |
0

Check this https://gitlab.com/jenslody/gnome-shell-extension-openweather/-/issues/272

But for me workaround doesn't work on 20.04 :(

My own workaround in ~/.local/share/gnome-shell/extensions/openweather-extension@jenslody.de/extension.js on 1116 after

_httpSession = new Soup.Session(); 

add

_httpSession.ssl_strict = false;

works fine for me.

| improve this answer | |
  • I followed the link from Jens in 18.04 LTS but even after F2 r it still doesn't work for me. – User24601 May 31 at 11:51
  • This solution involves some coding experience which some users might find daunting but the answer provided by Andrew is much easier to follow why is why it gets my upvote. – User24601 May 31 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.