7

I currently using Alacritty terminal. Shortcut works fine. But when I click "Open in Terminal" in context menu, it still pops up the gnome terminal. So is there any way I could change to Alacritty?

2
  • 1
    Same question here, askubuntu.com/questions/1179589/…, but also without valid answer
    – vanadium
    May 31, 2020 at 8:36
  • That menu entry is specifically added there by gnome-terminal's nautilus plugin, so, by design, it opens gnome-terminal. I don't think there's a ready solution for other terminals.
    – egmont
    May 31, 2020 at 9:46

2 Answers 2

5

I installed manually and put the executable in /usr/local/bin

I run this command taken from here to add an alacritty alternative:

sudo update-alternatives --install /usr/bin/x-terminal-emulator x-terminal-emulator /usr/local/bin/alacritty 50

then I run @walttheboss command:

sudo update-alternatives --config x-terminal-emulator

If you want remove alacritty alternative this is the command:

sudo update-alternatives --remove "x-terminal-emulator" "/usr/local/bin/alacritty"
1
  • 1
    Thank you @israteneda this worked for me.
    – Rishabh
    Oct 1, 2020 at 14:52
2

I would recommend you read this page.

sudo update-alternatives --config x-terminal-emulator

It will show all the terminal emulators present on your system that can be used as default. The current default terminal is marked with the asterisk.

All you have to do is to enter the selection number.

2
  • 2
    I did this solution already. As I mentioned above, shortcut works fine but the "Open in Terminal" still opens Gnome terminal.
    – Huy Duy
    May 31, 2020 at 7:53
  • Thanks for clarifying. I thought that changing the default would correct the problem. If you want a particular file type to be opened in terminal then you can associate that with alacrity. Right click then adjust file type options to your liking. Then you can "open with" and pick terminal. May 31, 2020 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .