I'm trying to open System Settings but it won't open in any way.
Using GUI, Settings are trying to load for a moment and then they are gone.
Using Terminal (gnome-control-center), I get:

(gnome-control-center:8823): GLib-ERROR **: 14:44:15.433: ../../../glib/gmem.c:138: failed to allocate 13477064712 bytes
Trap Trace/breakpoint (core dumped)

I tried:

sudo apt-get remove gnome-control-center
sudo apt autoremove
sudo apt-get install gnome-control-center

With multiple reboots, but I had no result.

UPDATE!: Same errors persist BUT, when I type:

sudo gnome-control-center

(instead of just "gnome-control-center") suddenly System Settings appear! Is it a user permissions issue? Any suggestions?

UPDATE#2: After some system updates, sudo gnome-control-center now spawns "Segmentation fault".

  • 1
    it may be related to this bug gitlab.gnome.org/GNOME/gnome-control-center/-/issues/342 However try this XDG_CURRENT_DESKTOP=GNOME gnome-control-center – kenn May 30 '20 at 12:55
  • Does this help? forum.level1techs.com/t/… – Ollie May 30 '20 at 13:23
  • @kenn doesn't work. It spawns the same error. – Zerthimon May 31 '20 at 0:02
  • @Ollie I installed hidpi-daemon but still, I get the same error when I'm trying to open system settings. – Zerthimon May 31 '20 at 0:07
  • getting the same issue. not sure if anyone else has been getting this but i've noticed my online accounts were not longer signed in. i signed back in but see no option for them in Files. – hangejj Jun 2 '20 at 2:16

Finally I found a solution!
The cause of this problem was pop-theme, that I installed once, plus its repository entry, that provided me the broken System settings (gnome-control-center). In order to solve this:

  1. I installed Ubuntu desktop PPA.

    sudo add-apt-repository ppa:ubuntu-desktop/ppa
  2. I removed all System76/pop (and other trush) entries, with update-manager, leaving Ubuntu desktop the only one active. update-manager

  3. Now that I have the proper repository entry added, I re-install gnome-control-center.

    sudo apt install --reinstall gnome-control-center
  4. Enjoy Gnome System settings!

  • 2
    System76's employee themselves don't recommend using Pop!_OS' PPA over Ubuntu. – Kulfy Jul 23 '20 at 18:28
  • I didn't have System76/pop at all, but following your procedure resolved the problem for me. All I removed was the entry for WineHQ. – Peter Gloor Feb 21 at 12:43

I had the same issue. I was able to fix by removing the GNOME extension/theme which caused the issue and then running:

sudo apt install --reinstall gnome-control-center
  • Just reinstalling gnome-control-center didn't solve my problem. I had resolve the repository issue (as seen on my and @nobody 's solution). – Zerthimon Oct 25 '20 at 13:53
sudo apt install ppa-purge

For the next step the PPA has to be active.

sudo ppa-purge ppa:system76/pop

This removes packages from this PPA if they are not available from Ubuntu repositories, or reverts to Ubuntu package versions.


Hmm... a variant of this:

  • Ubuntu 20.04.1 LTS
  • No Pop!_OS' PPA - present.
  • sudo gnome-control-center # worked, from a terminal/shell,
    but not so without 'sudo', no GLib-ERROR, with no output at all.
  • "Ubuntu software" - also affected, didn't try 'sudo' there though.
  • dconf reset -f /org/gnome/control-center/ didn't appear to help.
  • Neither did the apt --reinstall below.


  • Reboot into "recovery console"
    hit ESC ONCE after the BIOS displays to get to the boot menu)

  • run the "dpkg" option to install / fix packages
    this brought in a gcc1 -thingie, didn't pay attention to exactly what*

  • also run fsck option

  • enable networking

  • drop to root prompt,
    press ENTER one extra time at the extra prompt

  • run:

$ apt-get install -f --reinstall gnome-control-center gnome-control-center-data
$ reboot

Remedy worked only as it was run in recovery mode.

  • 1
    dconf reset -f /org/gnome/control-center/ worked for me – JPG Feb 7 at 15:28

I faced the same issue on 20.04. I clearly remember at the time of Ubuntu installation system settings was working perfectly, but out of nowhere this problem arose. What i did:

  1. Reset the gnome-control-center by sudo dconf reset -f /org/gnome-control-center (but the problem didn’t go away).
  2. Then I tried to access settings through the terminal by typing gnome-control-center, but it said I don’t have this installed.
  3. After installing gnome-control-center by sudo apt install gnome-control-center I rebooted and it fixed my problem.

What worked for me was resetting all configurations of the control-center with the following command:

dconf reset -f /org/gnome/control-center/

This works until I click on "Display" in "System Settings". Then it stops working and I need to run the command again.

This was tested on Ubuntu 20.04.1 LTS (x86_64).

  • it worked but when I click on display in settings System settings are closed and i had to run reset dconf reset -f /org/gnome/control-center command again. basically you do not click on Display in System setting. – Chaman Narved Oct 22 '20 at 19:16
  • Have you tried the solution I suggested or @nobody 's solution? – Zerthimon Oct 25 '20 at 13:48
  • Yes I tried every solution we have here. nothing is working. – Chaman Narved Oct 26 '20 at 14:19

I had the same problem and looking at the question and answers here, I checked gnome-control-center in the terminal and it was not installed. Installing it solved the problem. I have no idea what happened.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.