0

After installing x64 Ubuntu 20.04 the driver for the integrated video card was not installed. The OS hands after login. Hard reboot or power off is required. Changing linux grub 'nomodeset' load option is a temporary solution, the OS is loaded in low resolution without graphics driver. The device is laptop Hewlett-Packard HP Pavilion dv7 Notebook PC, video adapter is Intel(R) HD Graphics 3000 (2108 MB) , 3D Accelerator: AMD Radeon HD 7690M XT (Whistler)

GPU:

1) Integrated: Intel Sandy Bridge-MB - Integrated Graphics Controller (MB GT2)
2) PCI Express 2.0 x16: AMD Radeon HD 7690M XT (HP)

enter image description here

when the OS was installing and loaded for the first time, I noticed error message that the video driver for the radeon video card was not installed.

[radeon]] *ERROR* No UMS support in radeon module!

Software & Updates -> Additional Drivers dialog shows no results (zero options).

enter image description here

after reading through forums and discussion boards, I learned that installing Intel tools, intel-driver for graphical card under x64 Ubuntu 20.04 is causing even more trouble, so that people are looking how to rollback that or purge. The Intel® Graphics Tool for Linux is not helpful and causes same frozen screen as default one.

My questions is why the OS is trying to use Radeon card if there is fully functional integrated Intel video card?

How can I switch to use only integrated Intel video adapter in Ubuntu 20.04? Is there driver for the Intel HD 3000 compatible with x64 Ubuntu 20.04?

I've changed BIOS option to use FIXED graphics card mode, so that the OS can't switch cards dynamically. Though there might be Ubuntu or linux configuration which defines video adapter in use. I'd like to set it to Intel ( there are no drivers yet for the Radeon under Ubuntu 20.04 )

Why video driver for the same video card Intel(R) HD Graphics 3000 that works fine for the Ubuntu 19.04 or 18.04 or 16.04 is not compatible with Ubuntu 20.04? Are there any breaking changes that make drivers incompatible?

    $ lspci -nnk | grep -i vga -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
    Subsystem: Hewlett-Packard Company 2nd Generation Core Processor Family Integrated Graphics Controller [103c:185e]
    Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] [1002:6740]
    Subsystem: Hewlett-Packard Company Radeon HD 7690M XT [103c:185e]
    Kernel modules: radeon

    $ sudo lshw -C video
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Whistler [Radeon HD 6730M/6770M/7690M XT]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller cap_list
       configuration: latency=0
       resources: memory:a0000000-afffffff memory:c6500000-c651ffff ioport:5000(size=256) memory:c6520000-c653ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:6000(size=64) memory:c0000-dffff
5
  • This system doesn't require installation of any drivers both Intel and AMD drivers are included in Linux kernel. I suggest to reinstall the system and don't try to install anything. It should work by itself.
    – Pilot6
    May 30 '20 at 8:18
  • yes, I've tried to re-install few times, same result. There is no difference, The screen is frozen after login. Disabling video driver temporary solves the problem. May 30 '20 at 8:27
  • Does the system work from LiveUSB? If not, did you try another release like 18.04? I have the same hardware working on 18.04 without any glitch.
    – Pilot6
    May 30 '20 at 8:29
  • And it seems that setting FIXEG graphics in BIOS is wrong. I suggest resetting BIOS to defaults.
    – Pilot6
    May 30 '20 at 8:30
  • indeed, the modified bios setting has no influence to the problem. Nope, it hangs from the live usb as well - only when graphic interface is loading. Yes, I've tried 18.04 - same problem. May 30 '20 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.