0

so i have ubuntu server 18.04, when i try to boot, alot of "depends" fail to start thus i cant boot the server

going to recovery mode i saw one line says memory exhausted, in recovery mode i use free -m and top i see really my memory is stuck at 7.8GB

top output:

KiB Mem : 8040724 total, 135060 free, 7873212 used, 32452 buff/cache

last thing i was doing is importing something to PostgreSQL, and it was stuck at around this much, even after finishing the import, so i restarted and never made it back

btw tried

#sync; echo 1 > /proc/sys/vm/drop_caches
#sync; echo 2 > /proc/sys/vm/drop_caches
#sync; echo 3 > /proc/sys/vm/drop_caches

still same problem

1
  • I Tried to do memory test from hp bios, says it passes test tried to boot live ubnutu 20.04 it shows that my used ram is ~700MB and free is 7.xGB still when i boot to server it takes forever to enter the recovery mode, and still wont boot in normal mode :/ – Ve3lst May 30 '20 at 9:29
0

well, i didnt figure out what i did wrong, so i reinstalled the server. and while doing the steps again i noticed where i did go wrong. i was 'following' the steps of this guide: How to Set Up OpenStreetMap Tile Server on Ubuntu 18.04

at one step i should edit /etc/sysctl.conf

sudo nano /etc/sysctl.conf

and add certain value (depending on my setup) to vm.nr_hugepages, for guide it was:

vm.nr_hugepages = 7950

They use 7950 because they have a lot of virtual memory?. so this value is fetal for my setup!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.