7

My builtin webcam stopped working after a kernel update issued after 22 April 2020 . Before this date i was able to take pictures on cheese and video call etc , and for a while i didn't use my webcam until yesterday i noticed that my webcam is getting detected as "usb 2.0 web camera" but its not working at all . Cheese shows a black screen when opened and Firefox asks for permission and then nothing happens . So i changed the kernel to version 5.0 and webcam started working properly . But i need to work it on the latest Ubuntu kernel . Any help will be thankful .

output of sudo lshw:

*-usb:1
    description: Video
    product: USB 2.0 Web Camera
    vendor: Alcor Micro, Corp.
    physical id: 2
    bus info: usb@1:1.2
    version: 0.08
    capabilities: usb-2.00
    configuration: driver=uvcvideo maxpower=200mA speed=480Mbit/s
14
  • 1
    If you are sure it is a kernel then you either have to wait or use the old kernel. Just guessing maybe you can install a snap of cheese and see is that see the webcam. You can try lsusb to see if the device is there and given a number. You can sudo lshw and see if the hardware profile(name and model) of the webcam come up correctly. You can go to additional hardware drivers and see if there is something there. – walttheboss May 30 '20 at 2:29
  • @walttheboss question updated with ouput of sudo lshw . – Afsal May 30 '20 at 2:37
  • If you're on 20.04, why did you revert to kernel 5.0? It was never supported by Ubuntu/Canonical (testing only) and is now EOL, rather than a prior 5.4 kernel already on your system./ Are you using Ubuntu 20.04? – guiverc May 30 '20 at 2:55
  • @guiverc im on Ubuntu 20.04 . Any kernel released after 5.2 and before 5.6 slows down my system . And the only kernel version which is working good in this range is the default kernel in Ubuntu 20.04 .Other 5.4 , 5.3 versions from kernels.ubuntu lags very much . – Afsal May 30 '20 at 2:59
  • @guiverc i thought 5.0 was supported in 19.04 . And my webcam is not getting detected with latest mainline kernel . – Afsal May 30 '20 at 3:02
3

issue got solved with kernel 5.4.0-37-generic . https://bugs.launchpad.net/ubuntu/+source/linux-signed/+bug/1881757

3
  • 4
    For the records, the issue returns with newer kernel versions. The Launchpad link shared by Afsal mentions this is the case again with 5.4.0-52. I have been experiencing this problem with 5.4.0-54 – XavierStuvw Nov 21 '20 at 8:16
  • 1
    Still broken on 5.4.0-65 – michid Feb 11 at 14:13
  • 1
    Broken 5.8.0-50 – Windstorm1981 May 10 at 22:36
-1

For me there was permission issue.

The group and permissions for your /dev/video* files were icorrect. The group root for your /dev/video* will deny access to the camera for users outside this group.

The output of ls -l /dev/video0 should look like this:

crw-rw----+ 1 root video 81, 1 Apr 19 22:25 /dev/video0 crw-rw----+ 1 root video 81, 1 Apr 19 22:25 /dev/video1

Try fixing the group by running:

sudo chown root:video /dev/video*

Then fix permissions by running:

sudo chmod 666 /dev/video*

It worked!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.