5

This is very annoying, and is affecting the top and bottom panels. I had the problem with Eoan too, but I noticed it only appeared if I have a tty session opened as the same user when starting Flashback. Now that I've upgraded to Focal it can't get rid of it, even if Flashback is the first session opened as that user.

I tried explicitly setting the background and text color (Alt-Right click on the panel), but I didn't manage to get back to what is supposed to be the default anyway. I simply would like it to behave like it's configured to. Any advice ?

EDIT : To make things clearer, I use the default theme. I tried with the Intel and the Nvidia GPUs (I have an Optimus laptop), same problem. And here's a screenshot : GNOME Flashback desktop screenshot

Notice the white border of Windows too. It wasn't like that before...

2ND EDIT : It turns out my "problem" is not really one, the theme has changed in 20.04. So the problem would rather be "How to set the theme of Gnome Flashback to the previous default one ?"

7
  • Did setting background and/or text color work? What theme do you use? Commented May 29, 2020 at 22:04
  • @muktupavels As I said, I didn't manage to get what is supposed to be the default, even by explicitly setting the background to grey and the text to white. I mean it works, but then the indicator icons become more difficult to see, because they don't become white as the text does. It seems somehow that everything has become inverted, text, background and icons. Using Compiz instead of Metacity gives the same result, as does using the Intel iGPU instead of the Nvidia dGPU (I have an Optimus laptop).
    – NovHak
    Commented May 30, 2020 at 14:28
  • Oh and I use the default theme (which is supposed to have a grey background). Maybe there's a GTK-related problem ?
    – NovHak
    Commented May 30, 2020 at 14:30
  • 1
    Try to reset theme - gsettings reset org.gnome.desktop.interface gtk-theme and icon theme - gsettings reset org.gnome.desktop.interface icon-theme. And maybe attach screenshot? Commented May 30, 2020 at 15:25
  • 1
    Panels looks correct to me. In 20.04 default theme changed from Ambiance to Yaru. Do you have compositing-manager enabled - gsettings get org.gnome.metacity compositing-manager? Commented May 30, 2020 at 16:21

2 Answers 2

5

So, for people like me wondering why the theme changed in their Gnome Flashback session since Focal, and how to get back to the previous default one, it's not a bug, the default GTK theme changed from Ambiance to Yaru, and the icon theme changed from ubuntu-mono-dark to ubuntu-mono-light.

HOW TO GET BACK TO THE PREVIOUS (AS OF 19.10) DEFAULT THEME :

  1. As admin : apt install light-themes

Then, as the user wanting to change the theme :

  1. gsettings set org.gnome.desktop.interface gtk-theme Ambiance
  2. gsettings set org.gnome.desktop.interface icon-theme ubuntu-mono-dark

And voilà, back to the previous theme !

Thanks to @muktupavels for pointing me in the right direction.

2
  • This is great, but the colour of the desktop icons turn to an almost unreadable grey
    – DaraJ
    Commented Jul 30, 2020 at 23:00
  • The best I have found was to set the gtk-theme to Yaru-dark. It's slightly different and you get dark windows, but I kinda like it :)
    – DaraJ
    Commented Aug 1, 2020 at 13:28
0

The "unreadable grey" mentioned by Dara Jara can be fixed by adding these lines into /usr/share/themes/Ambiance/gtk-3.20/apps/gnome-flashback.css:

gf-icon label {
color: white;
text-shadow: 1px 1px 2px black;
}

See: https://ubuntuforums.org/showthread.php?t=2472913

1
  • Thanks for your contribution ! Unfortunately, despite considering that Gnome Flashback is better than Gnome 3 in more than one respect, what kills it for me is the lack of dynamic or on-demand VSync. I really hope it will be addressed one day.
    – NovHak
    Commented Nov 6, 2022 at 3:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .