An extremely annoying prompt randomly appears when im using specific apps. It happens the most when i run Neofetch. Here is a screenshot:

enter image description here My question is: how can I disable it and why does it happen in the first place.

Info that may be useful (Or you can just read the neofetch in the screenshot): OS: Ubuntu 20.04 LTS x86_64 Kernel: 5.4.0-31-generic Host: HP EliteBook 840 G1
GPU: Intel Haswell-ULT GPU 2: AMD Radeon HD 8730M I am dualbooting with Windows too.

Update: I installed KDE Plasma Desktop and it still happens. I think it happens when a program tries to fetch display information, but I'm just speculating.

Update: If I use lightdm and logout, it appears before its logs me out and the same thing happens when I log in.

Update: KDE crashes if I log in and out with error message: VCE init error

Update: I wiped my SSD and reinstalled Windows. I am having too many problems with Ubuntu. I might go with an Arch based system.

Update: I removed Windows and Ubuntu, then installed Arch. The problem still occurred. I answered it below.

  • Your problem is very weird . To get started , can you post the output of following command ? (e.g via pastebin ) : "strace neofetch 1>/dev/null " ( warning : there will be a huge number of lines in the output of strace.) – Parsa Mousavi May 30 '20 at 15:40
  • Here is a link: drive.google.com/file/d/1TJXqGsU2VpzSHN_tMJYnlDWP74anyk0r/… If you are a windows user, rename it to .txt (for some reason its not .txt on drive) – me is me Jun 4 '20 at 14:20
  • Check all the cables and ports for your displays. This can come up when a new display is detected. I would not be surprised if you have a loose, damaged, or faulty cable or port. – Nmath Jun 4 '20 at 15:55
  • It is not a faulty cable or port. If I remove the cable and replug it, the window does not show up. It only shows up when I run neofetch or Dos Box for example. And, it does not happen on Windows 10. – me is me Jun 4 '20 at 16:20
  • 1
    if you managed to fix it feel free to answer your own question – Fuseteam Oct 24 '20 at 1:28

The problem still occured on Arch, turns out the Radeon driver was the issue. I switched to AMDGPU and everything works fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.