7

I recently installed the Brave Browser using the method on their website (I do not believe I used snap; I believe it was via apt). Every time I open it, the browser asks for me to enter my password so it can access my keyring. I do not want to do this.

Every time I start the browser, I have to "cancel" out of the keyring dialogue three times before it lets me go about my business. Is there a way I can prevent it from asking this question again?

I do not use auto-log in.

6
  • I'm pretty sure you can write an AppArmor profile that prevents Brave Browser from accessing the Keys & Password service in the first place. That will not be easy, however. You should start here: linux.org/threads/securing-ubuntu-with-apparmor.26523
    – Jos
    Commented May 29, 2020 at 13:09
  • Did you add Brave keyring?
    – JoKeR
    Commented Jun 23, 2020 at 20:21
  • @JoKeR I used the installation instructions from here brave-browser.readthedocs.io/en/latest/… and while the word "keyring" appears in the command, I do not know if it is installed or not. brave-keyring --version does not return anything. Do you know how to install it?
    – zim
    Commented Jul 1, 2020 at 2:15
  • I try to figure it out too. Very annoying Commented Dec 18, 2020 at 18:56
  • 2
    The keyring in the link is talking about the keyring for your Linux system's package manager. You're adding the Brave gpg key they use for signing packages to your trusted list. It has nothing to do with the popup where Brave tries to access your system keyring to store saved passwords (even if that function is disabled in Brave).
    – mtalexan
    Commented Oct 12, 2022 at 16:18

4 Answers 4

3

Check How to disable the "unlock your keyring" popup?

There's many ways.

I choose mine: remove gnome-keyring, I don't need it:

apt remove gnome-keyring
3
  • Thanks for the helpful link... But what are the implications of removing gnome-keyring?
    – zim
    Commented Dec 18, 2020 at 21:53
  • 2
    None if you don't use it explicitly. Commented Dec 27, 2020 at 0:20
  • 3
    Most answers I'm finding seem to be to either remove your system keyring, or make the system keyring passwordless. Both are completely unreasonable options for the large number of people that do actually use the keyring for saving passwords on their Linux system.
    – mtalexan
    Commented Oct 12, 2022 at 16:17
0

If you navigate to the following folder: home/.local/share/keyrings

You can delete the respective default keyring file.

.local is a hidden folder, so you will not appear in file folder until you select show hidden files option (located in the little box with the three horizontal lines).

-1

Brave V1.45.131 installed on Linux Ubuntu 22.04 LTS:

Settings → Autofill → Passwords → Disable offer to save password

-2

Settings > Additional settings dropdown > Autofill > Offer to save passwords

I tried that process!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .