I have a Canon PIXMA TS8351 connected in LAN by WiFi to a router. I can access, print, and scan from different Windows computers but I don't know how to access the printer from a computer on Ubuntu 18.04.

On my Ubuntu computer, I've downloaded the following drivers that I found on the Canon website: IJ Printer Driver v. 5.90 for Linux and ScanGear MP v. 3.90 for Linux. I've tried to install the first but the installation failed because the printer is not detected.

However, with the system-config-printer command, when I connect to localhost, I can see the printer and the print of a test page works fine. But, when I go on Printers in the system settings, I get an error message telling something like (translation from French): "Sorry! The printing service of the system does not seem to be available".

I've tried to delete and reinstall cups but it doesn't produce any change.

Note: I've tried to put here some outputs from command line to give information that may help but AskUbuntu complains that "This looks like spam"...

Many thanks for your help!

1 Answer 1


I solved this problem by changing IP address in /etc/cups/client.conf from

ServerName 172.16.x.xxx


  • Can you explain what the 172.16.x.xxx configuration was there for in the first place? Had you moved the computer to a different network or something? Jul 25, 2022 at 23:08
  • Yes, I had moved the PC to a different network. If I recall correctly, an IT guy changed the IP configuration.
    – TVG
    Jul 27, 2022 at 6:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .