0

Edit 2: Problem solved by disabling OOM killer and overcommit.

G'day,

I'm running 4x8GB sticks of corsair vengeance LPX RAM, a 5700xt and an r5 3600x.

I just installed ubuntu 20.04 a week ago to dual-boot with windows and I've been having RAM-related problems. Google chrome pages have been crashing with the aw, snap error: SIGSEGV. Chrome will also completely crash if I have too many tabs open. I ran memtest86 from the ubuntu boot menu and it freezes at 16% on the first pass when I have all my ram in and 35% when only 2 sticks are in (doesn't seem to matter which two sticks or which DIMM slots, either). I've yet to be able to get past 2 seconds into a memtest86 test.

I don't have these issues when I run windows as the OS and the Windows Memory Diagnostic didn't return any errors. It seems like the issues come when I try to access more than a certain amount of RAM in Ubuntu but I'm not sure.

The command free -m shows the amount of memory i'd expect.

Does anyone have any thoughts? I've tried installing PPA drivers for my GPU and had a look at the latency timings for my RAM in the UEFI but no luck.

Cheers.

Edit: Memtest86 freezes 2 seconds into the first pass in Ubuntu but runs for hours with no errors when booted from USB. Both chrome and firefox frequently crash on Ubuntu but run perfectly under much more stress in Windows 10.

12
  • 1
    If memtest86 shows problems with the RAM, then it's probably faulty. The fact that you encounter problems in Ubuntu and not on Windows might only mean that Ubuntu accesses other areas of the RAM than Windows does, or is less tolerant when it comes to faults. Did you try all possible combinations of RAM sticks to rule out a possible faulty one? Remember it is also possible that two of the sticks are faulty.
    – Sebastian
    May 29, 2020 at 7:42
  • Well memtest86 doesn't actually run long enough to find an error, it just freezes at the same. I tried a bunch of ram combinations and thought I covered most of them. Will do another test because I couldn't get it to post with a single stick but I only tried it for two of them. Just seems weird that I only have the problem while running Ubuntu and my ram seems fine on windows while doing more RAM-intensive tasks.
    – RuddyDev
    May 29, 2020 at 8:47
  • memtest86 is OS-independent, that's why I think it's rather not the fault of the OS. And yes, usually you have to use the RAM slots in pairs, so you will have to switch around until you find the one(s) that give problems. Be aware that some memtest86 checks run quite a long time though. But it should definitely run longer than 2 seconds.
    – Sebastian
    May 29, 2020 at 9:24
  • @Sebastian I did a bunch more tests running memtest through the ubuntu boot menu and had the same issue (ubuntu freezing) with each possible 2-stick combination of ram. I downloaded memtest onto a USB and ran it that way for a couple hours (with all my RAM sticks in) and it found zero errors and had no problems running. Memtest still freezes after 2 seconds when I run it through ubuntu. Again, I have zero memory-related issues running windows 10 but am still having chrome and firefox tabs either crash with errors or just have the whole application quit when running Ubuntu. Any suggestions?
    – RuddyDev
    May 31, 2020 at 9:37
  • 1
    I would poke around a little more before reinstalling the whole system. Firefox usually isn't that memory-intensive, Chrome maybe more so, but it still seems weird that they consistently crash while using maybe 5% of your RAM. Try using some other programs that use a lot of RAM. Also, have journalctl --follow run in a terminal and see if it says something when there is a crash. And if you're using snap packages, try using an apt package or a manual installation instead - snaps are often not very stable.
    – Sebastian
    Jun 1, 2020 at 8:26

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.