0

Background - I was originally trying to resolve the issue of Question - No audio in laptop speakers or headphones, but sound plays in screen (HDMI connection), I suspected kernel update and with the help from comments in Question - In the package logs, what are the kernel updates listed as?, I was able to discern kernel version I wanted to try booting into to see if the issue is resolved.

Right now, I have managed to install the kernels for specific version by installing appropriate linux-image(s) and the linux-header(s) only, but when I do boot using these kernels from the GRUB menu, the OS can not find my WiFi Adaptor, and for the sound it shows "Dummy Output". I installed 3 kernels on top of the existing one, and this issue is happening with them all.

Am I missing a crucial step or detail here?

3
  • Did you also install linux-generic?
    – chili555
    May 29, 2020 at 1:07
  • I'm having a similar issue. I have been using Ubuntu 18.04 on this laptop since I got it in 2018. Yesterday suddenly this no sound problem and only Dummy Output shown as the only option for device under sound output in settings. But I still had wifi yesterday and now that is gone too, showing "no wifi adapter found" in settings. I'm not really a tech person, would really appreciate a simple easy to follow solution for whatever weird malady is affecting my system.
    – Pema
    May 14 at 20:41
  • You know what resolved it for me in the end - installing all updates. I was running dual boot with Windows. I went ahead and installed every update that I had been ignoring - windows, bios, and ubuntu. Something in there just fixed it. May 15 at 2:20

1 Answer 1

0

I have managed to install the kernels for specific version by installing appropriate linux-image(s) and the linux-header(s) only

In order to get the required kernel modules; that is drivers for wireless, ethernet and many more, you also needed to install linux-modules-xxx-generic as well as linux-modules-extra-xxx-generic, where xxx is the kernel version that you installed. Find out with the terminal command:

uname -r

It appears that this step was missed.

If you installed these kernels from the preferred Ubuntu repositories, you can go here and find the debs to install: https://packages.ubuntu.com/

If you installed these kernels from Ubuntu mainline, for example, here: https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.6/ then you will notice that there is, in addition to linux-image and linux-headers, a package called linux-modules. Wireless, ethernet and many other drivers are included.

If you installed these kernels from some other source, please specify so that we may help you further.

2
  • Thank you. The linux-modules-xxx-generic was already installed, I found out when I tried to, but linux-modules-extra-xxx-generic, I had to install. After I did, the wifi is working the sound is still not. I think you are right about what I missed. Do you know which particular package I might have missed to install for the audio drivers? May 29, 2020 at 16:55
  • Not without knowing what sound device you have. sudo lshw -C multimedia Have you tried selecting a different output device in Settings > Sound?
    – chili555
    May 29, 2020 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.