4

How do I explicitly add specific languages to "Tools > Language > All Text" in LibreOffice Writer?

0
  1. Download the desired language extension (*.oxt file) from here

  2. After download right-click on this file and select open with libreoffice

  3. Open libreoffice writer and open "Tools > Language > All Text" and select "more"

  4. Now "Options- Language setting" will open. Here select desired language in "Locale Setting" tab and press apply. You are done.

| improve this answer | |
  • Doesn't work if you want more than one language in the menu. – EmmanuelMess Jun 3 at 12:17
  • Yes when you select a specific language you will be able o see specific language. What you can do install different keyboard layout specific to the language. Whenever you will change the keyboard layout from panel shortcut LibreOffice automatically change to that language. – Ajay Jun 3 at 14:01
  • "Whenever you will change the keyboard layout from panel shortcut LibreOffice automatically change to that language." Why would I want LibreOffice to change language? – EmmanuelMess Jun 3 at 14:03
  • For the same purpose for which you want to add specific languages to "Tools > Language > All Text" in LibreOffice Writer. Here from panel I mean OS panel. Whenever you need to change from one language to another language within the document you can keep selecting different keyboard layout. that is the way. – Ajay Jun 3 at 14:09
  • 1
    This will further surprise you. What I am telling you was once reported as bug in LibreOffice. Hence an option "ignore system input language" was added since LibreOffice v4.0. You can refer LibreOffice forums. What I can suggest you contact LibreOffice Forum and either request this "feature" or ask there. – Ajay Jun 3 at 16:28
0

As ajlittoz answered:

AFAIK, there is no way to make the UI dependent on custom configuration (I mean users may load additional language packs, every user having different need from another one).

Since your question is about All Text, this means you intend to write a document in one of the cited languages. Even if you have a few paragraphs written differently, you basically end with a document in a dedicated language.

My best advice is to create as many custom templates as you have main target languages: one for en_UK, one for es_SP, one for es_AR. The main difference between these template is in paragraph style Default Style Font tab where you set the language once for all.

You can also customise the paragraph styles if cultural typographical rules differ with the languages. For example, in en_US, paragraphs have usually no first line indent while in other languages it is customary to have a first line indent. This difference can be recorded in Text Body.

When you create a new document, you start from the appropriate template.

The solution seems to be adding templates.

| improve this answer | |
-2

Install the corresponding package. For German, I used: sudo apt install libreoffice-l10n-de This will suggest more packages that might interest you. If the language is not available in LibreOffice, setting the environment variable LANG should help.

| improve this answer | |
  • Will this add the language to the Tools - Language - All Text menu (and other entries). I think not. The question is how to add an installed language to these menus. Now, you need to select "More" to select them from the Options - Language settings dialog. – vanadium May 29 at 18:12
  • @vanadium Not it will not. "Now, you need to select "More" to select them from the Options - Language settings dialog" I dont think it allows you to select more than one. – EmmanuelMess May 29 at 19:22
  • After installation of your language package, you must restart LibreOffice. Then, the new language should be listed in "Tools > Language > For All Text'. @EmmanuelMess What language are you looking for? – Sven May 29 at 20:27
  • @Sven It doesn't work. 3 languages, "English (UK)", "Spanish (Spain)" and "Spanish (Argentina)" – EmmanuelMess May 30 at 2:54
  • 2
    Confusing comment from your side as you are the one asking the question, not the one posting this answer. I agree fully with you that this answer will not add the language to the menu, so the answer is not valid. That is what my comment indicated. – vanadium May 30 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.