Possible Duplicate:
How to Install Broadcom / STA Wireless card (BCM43XX)

the broadcom wireless card bcm43225 is not working. I have tried with proprietary drivers and firmware-b43-installer package, with or without acer-wmi blacklisted. The card is not soft/hard blocked.

output of 'rfkill list' 0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no

Can you suggest something?

Lubuntu 12.04 beta 2 Kernel 3.2.0-23-generic X86_64 04:00.0 Network controller [0280]: Broadcom bcm43225 rev 01 [14e4:4357] Acer Travelmate 5735


marked as duplicate by Luis Alvarado, qbi, Jorge Castro, Ringtail, Eric Carvalho Jan 24 '13 at 1:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


My configuration: notebook acer 5742 - ubuntu 12.04 x32 - card wireless bcm43225

Solution for problem in my computer:

  1. In the file: "/etc/modprobe.d/blacklist.conf" disabled the line: "blacklist bcm43xx" posing as commentary.

  2. At the command line:

sudo apt-get update

sudo apt-get --reinstall install bcmwl-kernel-source

Restart ubuntu ...

  • This solution worked for me. Thanks! – del May 27 '13 at 9:39

Can you try the 3.3.3 kernel? I couldn't getting working wireless on the 3.1.x or 3.2.x kernels on the BCM43225 but 3.3.x seems to be working.

Ubuntu 3.3.3-precise kernel

  • I have tried this morning with kernel 3.4rc4 and I have the same issue. According to Canonical developer, I have filed a bug report link – user56196 Apr 26 '12 at 6:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.