I've upgraded from 10.04 to 10.10 and subversion checkout from http:// just refuses to work anymore. Always timeouts.

I tried a 10.10 Live version and that works and all my packages are upto date.

The symptom is:

hendry@x201 tmp$ svn co http://tc.labs.opera.com/svn/apis/XMLHttpRequest/
svn: OPTIONS of 'http://tc.labs.opera.com/svn/apis/XMLHttpRequest': could not connect to server (http://tc.labs.opera.com)

I am out of ideas since subversion is too difficult to debug. Do I just re-install everything? Anyone seen a similar problem?

svn, version 1.6.12 (r955767)

I strongly suspect it has some thing to do with the neon library.

ii  libneon27                             0.29.3-2                                          An HTTP and WebDAV client library
ii  libneon27-gnutls                      0.29.3-2                                          An HTTP and WebDAV client library (GnuTLS enabled)
  • Are u facing the issue for all repo or just this one? – aneeshep Nov 10 '10 at 11:09

It works fine for me - I am also using 10.10. Can you browse to the repository in a web browser OK?

Have you tried again later? Maybe it was a temporary problem with their website that has since been fixed.

Another possibility is that there is something in your subversion config causing an issue. Maybe you could try

mv ~/.subversion ~/.subversion_old

And then try the checkout again.

  • agree with Hamish Downer . it works me too – aneeshep Nov 10 '10 at 15:55

I cannot replicate this issue with the same version of svn and libneon27. However, there is a related bug report over at Debian. From their discussion it seems that libneon 0.29.3-2 should have fixed the problem. It's possible there has been a regression, but considering multiple other users cannot replicate your problem with the latest version of the package I feel like this is relatively unlikely.

There is a workaround suggested on the Debian bug tracker. Try editing ~/.subversion/servers and adding the line:


To the end of the file. If this does not correct your issue it becomes even more unlikely that libneon has anything to do with your specific issue.


I think the subversion adress is wrong (http://tc.labs.opera.com/svn/apis/XMLHttpRequest/) When i browsed the http://tc.labs.opera.com/ there is no svn library

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.