0

I recently upgraded my Lenovo PC (16-GB RAM; 2TB-HD) from Ubuntu 18.04 to 20.04. I had saved the ".bitcoin" directory (and subdirectories and files) to an external hard disk drive. Since then I have not been able to run Bitcoin Core successfully as I was able to in 18.04.

I installed the Bitcoin Core using the Ubuntu Software app in Ubuntu 20.04, and then substituted the new files with all the files in the backup of ".bitcoin" directory (along with all the saved subdirectories and files). I did this so that I would not have to rescan the entire blockchain which takes up to 2 weeks these days.

I did note that the new installation placed the ".bitcoin" directory in a new directory - whereas previously (in the Ubuntu 18.04 version) it had been in the home directory it is now in the /home/snap/bitcoin-core/common directory. For clarity I repeat that I replaced the new ".bitcoin" directory with the old ".bitcoin" directory (from my backup) - placing in in the "common" directory.

Now the Bitcoin Core starts fine, but gets stuck on "rescanning". I aborted the process after 3 hours and attach a screenshot of the message I was given which was: Error: Failed to rescan the wallet during initialization.

enter image description here

6
  • Have you installed a snap-version of the app, where the install on your 18.04 Ubuntu was native .deb ?
    – Soren A
    May 28, 2020 at 8:24
  • This Bitcoin Core is a snap package.
    – karel
    May 28, 2020 at 8:38
  • 1. The Bitcoin Core is in the snap dir (as indicated in my original post). (2) After installing the Bitcoin Core (on Ubuntu 20.04) I ran it BEFORE transferring-in my backup - and it ran fine - and started building the blockchain. I then transferred-in my backup ".bitcoin" files. The Bitcoin Core then ran but got stuck at the "scanning" stage (as indicated in my original post). Thank you for your help.
    – Duncan
    May 28, 2020 at 9:40
  • As it ran perfectly well before I transferred-in the back-up files I assume the snap package is present. Thanks.
    – Duncan
    May 28, 2020 at 9:47
  • Uncheck the network setting in the options inside Bitcoin Core. Then it should work. Jan 8 at 22:56

1 Answer 1

0

Solved the problem with patience! The rescanning took 5 hours! After that, worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.