3

I am trying to change the key to summon my Guake Terminal to Alt++` (backtick, the key above Tab) and only to find out that the key is occupied by GNOME for cycling through windows of the active application.

When I go into the keyboard shortcut settings I found that the exact same feature was displayed to be mapped to Super+` and both key combos behaves the same.

But since the Alt+` was not "assigned" to anything in settings, I cannot change it. Is there any command-line method that I can use to make GNOME not intercepting Alt+`?

2

You can remove Alt+` key combo via dconf Editor or gsettings

gsettings get org.gnome.desktop.wm.keybindings switch-group

Example:

$ gsettings get org.gnome.desktop.wm.keybindings switch-group
['<Super>Above_Tab', '<Alt>Above_Tab']

By running below command, you are removing '<Alt>Above_Tab' key-combo

gsettings set org.gnome.desktop.wm.keybindings switch-group "['<Super>Above_Tab']"

Now you can assign any command to this key-combo via keyboard shortcut settings.

enter image description here

dconf-editor is not installed by default.. If you wish to change via GUI

install dconf-editor

sudo apt install dconf-editor

enter image description here

| improve this answer | |
  • Thank you! That perfectly solved my problem. I just switched from windows and there are a lot of stuff I need to learn. Is there any particular reason that Alt+` was not made easily configurable in settings? – Aaron You May 29 at 4:56
  • Hi.. not only that combo.. it is related to keyboard shortcut functionality.. if the key combo is already assigned and when you hit that combo in shortcut keys.. it will bring the command in action. so first you need to deactivate that combo. it applys to all. not particularly for Alt back tick.. – UnKNOWn May 29 at 5:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.