0

I've got a triple boot system going on with Windows, Ubuntu and Mac. (It is a hackintosh). I've got a problem, that is, my dedicated graphics card (Nvidia GTX 1660) isn't supported by Mac, so I wanted to boot Mac with the integrated graphics card of my processor (Intel i7 6700).

What I did is, as my screen has both a DVI input and a HDMI input, I plugged both a DVI to HDMI wire and a HDMI to HDMI wire to it, then one goes to the HDMI output of my dedicated card and the other one to the output of the motherboard (integrated one).

I have the Intel as the main card, but the system boots with both, in Mac it's not a problem since I have it configured so it doesn't recognize the Nvidia.

On the other hand, Windows thought I had 2 screens as it recognized both adapters, so I disabled the integrated card in it and now it uses the Nvidia card for everything (booting etc).

I have a problem when I boot Ubuntu though, it recognizes 2 screens, my screen loads the Nvidia Input (Screen 0 recognized by Ubuntu) but for some reason the login is on the other one (Screen 1). I've told it to just use Screen 1 in the settings, and it does when I have logged in, but outside of (at login) it it's still showing extended screens.

Is there a way I can force that setting accross all the system so it is like that when it boots and gets into the login too?

Thanks in advance!

0

I've found the solution here: Ubuntu 18.04 login screen Display settings

You have to change your settings as desired with your user logged in and then perform this two commands in the terminal:

sudo cp ~/.config/monitors.xml ~gdm/.config/monitors.xml

sudo chown gdm:gdm ~gdm/.config/monitors.xml

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.