1

My laptop sometimes freeze on boot, not reaching the login screen. The screen freezes on the Ubuntu logo. I googled a lot, most posts relates to a Nvidia driver issue, but my laptop does not have a Nvidia card. I seem to notice that the problem relates to prior using the laptop on battery, or maybe closing the lid.

Yesterday I was using my recently fresh installed Ubunto 20.04 on battery. I remember - hope I am not wrong - that after usage I shutdown (not suspend) the machine and THEN closed the lid (again I hope my memory is correct here).

This morning when I tried to boot the machine I was shown a frozen screen. Then I used the "Magic SysRq keys" - Alt+SysRq+"REISUB" to reboot the machine, and this time the system went up quickly. I then used journalctl to check the previous boot:

journalctl -b-1 -a --no-pager

The complete output can be found here https://gist.github.com/bingtimren/c82cd760bb4788c0e480e08900985c04

I'm not familiar with booting and kernel, but it seems to me that the problem is with logind service failing to start.

May 28 10:11:09 bing-e480 dbus-daemon[770]: [system] Failed to activate service 'org.freedesktop.login1': timed out (service_start_timeout=25000ms)
May 28 10:11:09 bing-e480 gdm3[895]: GdmLocalDisplayFactory: Failed to issue method call: GDBus.Error:org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.freedesktop.login1': timed out (service_start_timeout=25000ms)
......
May 28 10:12:13 bing-e480 systemd[1]: systemd-logind.service: start operation timed out. Terminating.
May 28 10:13:44 bing-e480 systemd[1]: systemd-logind.service: State 'stop-sigterm' timed out. Killing.
May 28 10:13:44 bing-e480 systemd[1]: systemd-logind.service: Killing process 798 (systemd-logind) with signal SIGKILL.
May 28 10:15:14 bing-e480 systemd[1]: systemd-logind.service: Processes still around after SIGKILL. Ignoring.

More information about the computer:

Lenovo Thinkpad E480
Memory: 16G
Processor: Intel® Core™ i7-8550U CPU @ 1.80GHz × 8
Graphics: Radeon 500 Series (POLARIS12, DRM 3.35.0, 5.4.0-31-generic, LLVM 9.0.1) / Mesa Intel® UHD Graphics 620 (KBL GT2)
OS: Ubuntu 20.04LTS64-bit

The system is the only OS on the machine and is default installed.

Can anyone help?

  • 1
    That is sure a long boot log. Try rebooting and selecting Grub's Advanced Options for Ubuntu submenu. The select recovery mode. See if that at least lets you log on. – WinEunuuchs2Unix May 31 '20 at 21:15
  • Hi Thanks for comment. I have since then logged in, after hitting the "Magic SysRq keys" - Alt+SysRq+"REISUB" to reboot. Just I have no clue why the boot freezed and how I can fix it to prevent it from happening again. I hope someone can interprete that long boot log and point out what went wrong and what can I do. – Bing Ren Jun 1 '20 at 1:09
1

I've got a similar problem. I looked into some logs of my failing boot and found the same thing I found in yours in line 612 following:

May 28 10:10:41 bing-e480 kernel: Trying to unpack rootfs image as initramfs...
May 28 10:10:41 bing-e480 kernel: Initramfs unpacking failed: Decoding failed
May 28 10:10:41 bing-e480 kernel: Freeing initrd memory: 48308K

there's some discussion about precisely that in the following link: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1835660

Somebody there suggests:

What I did was I changed

COMPRESS=lz4 to COMPRESS=gzip in /etc/initramfs-tools/initramfs.conf, then sudo update-initramfs -u

After, without a reboot I've changed COMPRESS back to lz4, and then sudo update-initramfs -u

And after the reboot that error is gone


I haven't tried it out, so no promises. Another person in the forum says it's just a cosmetic issue... If it's not, the problem might involve the whole 20.04 LTS

But maybe that hasn't got anything to do with your problem.

I'd be happy if you give an update as I am struggling with the error too

  • Hi willhold, thanks for commenting. Since my post, I experienced a second time this issue - freeze after usage on battery, rebooted with "Magic SysRq keys" - Alt+SysRq+"REISUB" without problem. Still, I don't know what't the cause or how to fix it, won't be surprised if this happen the third time and again..... I will post if I find a solution, but I haven't yet. – Bing Ren Jul 13 '20 at 3:47
  • However I doubt if "Initramfs unpacking failed: Decoding failed" is the cause. I checked my last boot, which is success, and it also contains this line. So maybe not... – Bing Ren Jul 13 '20 at 3:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.