4

In the last week, my standalone USB microphone has suddenly become incompatible with all other audio output devices. While my USB microphone is plugged in, regardless of the specified output device in Sound Settings, all audio output is sent through the microphone's 3.5mm monitor jack. This is new behavior; as recently as last week, I could use this microphone for audio input while using speakers or Bluetooth headphones as audio output.

How can I diagnose and fix this? Details are below.

System Specifications

  • Ubuntu version: 20.04 LTS
  • Bluetooth headphones: Jabra Move Style Edition
  • Microphone: Samson GoMic (wired, USB, has a 3.5mm audio jack for audio monitoring)
  • Speakers: Creative Pebble 2.0 (wired, USB, external power)

Steps to Reproduce

  1. Disconnect the USB microphone from the computer. Ensure that there are no speakers connected to the USB microphone's 3.5mm jack. Turn off the power to wired desktop speakers.
  2. Using the Bluetooth tab on the Ubuntu Settings window, pair and connect the Bluetooth headphones.
  3. Under the Sound tab in Ubuntu Settings, verify that "Jabra Move SE v1.0.0" is selected as the output device, and is configured to use "High Fidelity Playback (A2DP Sink)".
  4. Click the "Test" button to test the output. "Front left" plays in the left phone, and "Front right" plays in the right, as expected.
  5. Connect the USB microphone to the computer.
  6. Repeat steps 3 and 4. No audio plays from Bluetooth headphones.
  7. Disconnect the microphone.
  8. Power on the desktop speakers. Switch the output device to "Line Out".
  9. Repeat step 4. The test sounds play where expected.
  10. Connect the USB microphone and test the speakers again, as in steps 3 and 4. No audio plays from speakers.
  11. Connect headphones using a 3.5mm audio cord to the audio monitor jack on the microphone.
  12. Click "Test" in Sound Settings. It does not matter what device is specified for audio output. Audio plays through the headphones that are connected to the microphone.

Expected Results

While the USB microphone is connected, audio still plays through specified output devices.

Actual Results

While the USB microphone is connected, audio only plays through the 3.5mm jack on the microphone, regardless of what device is specified for audio output in Sound Settings.

What I've Tried

  • Turning the Bluetooth headphones off and on again. No change.
  • Unpairing and repairing the Bluetooth headphones with the computer. No change.
  • Rebooting the computer. No change.
  • Checking to see if system sounds are muted. They are not.
  • Switching USB ports that the microphone is connected to. No change.
  • While the microphone is connected, changing the output device. No change.
  • While the microphone is connected, changing the input device (even to a separate USB webcam/microphone). No change.
  • While the microphone is connected, plugging the 3.5mm speaker cord into an audio jack on my computer. No change.

It appears that my microphone has decided in the last week that it is the King of Audio, and when it's connected to my computer, all audio input and output must go through it. 😜

As asked above: how can I diagnose and fix this, so that I can use my microphone as an input device while using other speakers or headphones as output?

1 Answer 1

3

Install "pulseaudio volume control" which has more controls :

sudo apt install pavucontrol

Launch it and select the correct device as default in "input devices" and "output devices" tabs:
The default device is selected by clicking corresponding green button.

If problem, look in "configuration" tab and try profiles .

2
  • This did the trick. Thank you.
    – SpencerDub
    Jun 16, 2020 at 20:02
  • 1
    Other solutions suggest fiddling about with the /etc/pulse/default.pa file to disable automatic device switching, but this is the much better solution, as it allows you maintain the functionality but set default fallback devices. In addition, for USB microphones to implement both audio input and output devices, if you go to the configuration tab, you can configure the microphone to only use the "input" profile and lock it so that the output profile is always ignored.
    – Amr Bekhit
    Apr 7, 2023 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .