1

This suddenly started happening today on my Lenovo Thinkpad X1 Extreme Gen 2. The system configuration has not changed from when this issue did not occur.

I'm using NVIDIA's proprietary driver 440.82+really.440.64-0ubuntu6 to drive a Philips 276E8V plugged in via a USBC-DP cable, and a Dell WD15 dock with USB devices and headphones attached.

This issue does not occur if the display is never plugged in, but occurs if the display is unplugged before I press 'reboot'.

Distro & kernel: Kubuntu 20.04 LTS, kernel 5.4.0-31-generic

Specs: i7-9850H, GTX1650 Max-Q, 16GB DDR4-2666, HP EX920 NVMe SSD

May 26 16:06:09 jordan-ThinkPad kernel: INFO: task kworker/11:1:209 blocked for more than 120 seconds.
May 26 16:06:09 jordan-ThinkPad kernel:       Tainted: P           O      5.4.0-31-generic #35-Ubuntu
May 26 16:06:09 jordan-ThinkPad kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
May 26 16:06:09 jordan-ThinkPad kernel: kworker/11:1    D    0   209      2 0x80004000
May 26 16:06:09 jordan-ThinkPad kernel: Workqueue: events dp_altmode_work [typec_displayport]
May 26 16:06:09 jordan-ThinkPad kernel: Call Trace:
May 26 16:06:09 jordan-ThinkPad kernel:  __schedule+0x2e3/0x740
May 26 16:06:09 jordan-ThinkPad kernel:  schedule+0x42/0xb0
May 26 16:06:09 jordan-ThinkPad kernel:  schedule_preempt_disabled+0xe/0x10
May 26 16:06:09 jordan-ThinkPad kernel:  __mutex_lock.isra.0+0x182/0x4f0
May 26 16:06:09 jordan-ThinkPad kernel:  ? __switch_to_asm+0x34/0x70
May 26 16:06:09 jordan-ThinkPad kernel:  ? __switch_to_asm+0x34/0x70
May 26 16:06:09 jordan-ThinkPad kernel:  ? __switch_to_asm+0x40/0x70
May 26 16:06:09 jordan-ThinkPad kernel:  ? __switch_to_asm+0x40/0x70
May 26 16:06:09 jordan-ThinkPad kernel:  __mutex_lock_slowpath+0x13/0x20
May 26 16:06:09 jordan-ThinkPad kernel:  mutex_lock+0x2e/0x40
May 26 16:06:09 jordan-ThinkPad kernel:  ucsi_send_command+0x2a/0x60 [typec_ucsi]
May 26 16:06:09 jordan-ThinkPad kernel:  ucsi_displayport_enter+0x90/0x180 [typec_ucsi]
May 26 16:06:09 jordan-ThinkPad kernel:  typec_altmode_enter+0x4f/0x60 [typec]
May 26 16:06:09 jordan-ThinkPad kernel:  dp_altmode_work+0xde/0xf0 [typec_displayport]
May 26 16:06:09 jordan-ThinkPad kernel:  process_one_work+0x1eb/0x3b0
May 26 16:06:09 jordan-ThinkPad kernel:  worker_thread+0x4d/0x400
May 26 16:06:09 jordan-ThinkPad kernel:  kthread+0x104/0x140
May 26 16:06:09 jordan-ThinkPad kernel:  ? process_one_work+0x3b0/0x3b0
May 26 16:06:09 jordan-ThinkPad kernel:  ? kthread_park+0x90/0x90
May 26 16:06:09 jordan-ThinkPad kernel:  ret_from_fork+0x1f/0x40
  • It is stated in the logs that you can run this " echo 0 > /proc/sys/kernel/hung_task_timeout_secs " to disable this message . Have you run this ? – Parsa Mousavi May 27 at 6:47
  • See this . In the section " Solution for hung_task_timeout_secs " it's well explained. – Parsa Mousavi May 27 at 6:56
  • 1
    @K7AAY I updated the post with distro and kernel – Jordan Liu May 27 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.