1

I installed Ubuntu 18.04 as a second OS on a computer which had Windows 7 already installed. The computer had an Intel RST FakeRAID level 5. After a good deal of messing around, I finally followed the instructions in the top answer to this question. This worked fine... until one of my hard drives failed.

I replaced the drive, and booted into Windows, where I rebuilt the RAID volume with Intel Rapid Storage Technology.

Now Windows boots and functions perfectly fine, but Ubuntu hangs while booting.

What's going on, and how can I fix this? According to this page, mdadm is supposed to be able to handle Intel RST.

0

I tried to boot into recovery mode, and it dropped me to the initramfs shell, after telling me that fsck had found errors on my last partition.

Because I suspected that the RAID format used by the Intel RST tool in Windows was different from the RAID format used by mdadm in Linux, I was afraid to repair the filesystem with fsck. But after I had verified that the raid had been detected correctly, I finally ran fsck on the last partition. This solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.