I have been facing this issue from the last week after some update. Whenever my laptop wakes up from suspend state it just shows me a blank screen. Regardless of whatever I do(move my mouse, press keyboard buttons) it just refuses to wake up. I am forced to do a restart and lose all my unsaved files. Has this issue been reported for Ubuntu 12.04?

I am using a Lenovo X200 with Intel Mobile 4 Series Graphics Chipset. Please let me know if any body has found a fix for this.

  • This question should instead be filed as a bug report, thanks! Instructions here. Apr 23, 2012 at 22:51
  • Same problem here with a Thinkpad X220.
    – cossovich
    May 28, 2012 at 3:58

9 Answers 9


I has this issue on my X200. Workaround for me was:

Turn off screen lock in the "Brightness and Lock" settings.

The only problem is that it wakes without a password, which isn't too big of a deal for me.


I have this problem also, but with a desktop.
Currently using 12.04 X64 with an onboard AMD graphics and a ASUS 24" LED screen with HDMI.

If the system goes into suspend after 30 min, when I wake it up by keyboard or mouse, the only thing that is seen is the cursor AND my userid in top-right corner. This will last for about 2 or 3 minutes.

The cursor will change, as it is moved across the screen, depending on what the invisible contents of the screen are.

Eventually after a few minutes, the screen will re-appear. It is annoying- I have set my "suspend after" to the max- Seems that the max can be no more than one hour!

Hmmnn.. I just realized I'm now using Gnome-CLASSIC- perhaps THIS is the problem!
Will try to replicate this bu... um, "condition" by reverting to Gnome or Metro/Unity (or whatever Ubuntu's desktop is now called), to see if it happens there also.


Try the update from 2011/11/10 on this page (towards the bottom of the article). It will give you some logs on whats going on.

Steps 1 through 3 are also capable if fixing the inability to hibernate/sleep issue many have been having in Ubuntu. I've personally been using this fix for two years. **Book mark it! ;)



I know I'm supposed to answer the question, but I can't.

I can make a suggestion to maybe make the situation more bearable

If the problem is that the system isn't turning your LCD backlight back on, then you can probably turn it back on by

ALT+F1 (go to a text virtual console) and then ALT+F7 (go back to the graphical X display)

The ALT+F1 should cause the backlight to come on, and then you can get back to your session with the ALT+F7


I used to have a sort-of related problem with 10.10 (my laptop wouldn't sleep at all), I fixed it by uninstalling the "pm-utils" package and installing an older version (1.3.-something). Your problem might be different, but it might be worth a try!


Same problem here. It's not a problem with the lcd turned off (I know because I have that problem on startup... had it since 11.10) All I see is the white pointer on a blue-black screen. Tried Alt f1-2-3-4 to no avail. Have to force shutdown and reboot.

EDIT: The problem has magically gone away, after update I suspect : ) It still takes a little more time than it should to connect to the network after login, but that could simply be due to the sequence of actions. Other than that Precise Pangolin is purring like a Kute Kitten.


Disable VSync.

Anyway, in this blank screen, you can type the password and press Enter.

But to solve this problem (white blank screen or black blank screen) on screen locker, disable the VSync option on Unity/Compiz or under Desktop Effects on KDE.


I managed to fix this on Xubuntu 15.10 by unchecking Lock screen before sleep under Advanced in the Session and Startup preferences.


Here it suggests to disable KMS by booting and passing the option nomodeset to the kernel. I tried passing this option temporarily and then add it permanently as explained here.

For the impacients:

sudo -H gedit /etc/default/grub

At the line beginning with GRUB_CMDLINE_LINUX_DEFAULT, add nomodeset to the end. Save and execute:

sudo update-grub

Reboot and enjoy!

  • 1
    Unfortunately, this wasn't a definitive solution since the problem persists.
    – Felipe BM
    May 16, 2016 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.