HP Pavilion - 14-al103ne Ubuntu 20.04

'top' command shows irq/126-aerdrv always running eating a lot of CPU.Top screenshot

'powertop' and 'cat /proc/interrupts' also attached. Interrupts and Powertop

I come from 16.04 where i had a similar problem with a kworker. I tried disableing gpe17 interrupt but it never went away. Upgrading to 20.04 does not seem to have helped. Only the process name has changed in 'top' from 'kworker/3:1' to 'irq/126-aerdrv'.

proc/interrupts tell me 126 is the code for IR-PCI-MSI 481280-edge. I dont know how to further find the source. This process continues even when i suspend the laptop. So suspend never works, eats up battery and CPU continuously. Any idea on solving this would be greatly appreciated.

  • Looks like it may be dealing with Wakeup Signaling - Power Management Events blog.linuxplumbersconf.org/2010/ocw/system/presentations/279/… I am only going to guess here, but you can try resetting the Power Management of the system by removing all power, including the battery (if a laptop), then pressing the power button a few times to drain the motherboard of any memory. Plug all the power back in then try again. If the battery is not removable, power off, hold down the power button for about 30 seconds. Then power back on. – Terrance May 26 '20 at 14:15
  • Edit your question and show me sudo grep -i AER /var/log/syslog*. If that output is lengthy, post it at paste.ubuntu.com. Also show me sudo dmidecode -s bios-version. Start comments to me with @heynnema or I'll miss them. – heynnema May 26 '20 at 16:15
  • paste.ubuntu.com/p/kMG2WgbsrF @heynnema the syslog was too big to even paste over there. I looked through it. it was just filled with /var/log/syslog.1:May 24 02:20:15 rahul-HP-Pavilion-Notebook kernel: [ 519.303569] pcieport 0000:00:1d.3: AER: Corrected error received: id=00eb again and again. the bios-version is F.25 Thank you for the taking the time and interest. Much appreciated. – Rahul Iyer May 26 '20 at 17:05
  • Looks like there might be a work around for now on it, but it is always recommended to find out why the AER is receiving so many corrected errors on the PCIe PME. A work around is found at forum.calculate-linux.org/t/… by adding pci=noaer to your GRUB_CMDLINE_LINUX_DEFAULT= line in your /etc/default/grub file and running sudo update-grub and rebooting. – Terrance May 26 '20 at 17:52
  • OK, we've found it. Now let's see if we can figure out what device it is. Show me lspci -nn and lspci -tv. Also, I tried checking for a newer BIOS than F.25, but the HP web site wants a serial number, so you'll have to check for that yourself. The BIOS may be an important fix for this problem, so don't wait on this. Don't try the pci=noaer workaround yet. – heynnema May 26 '20 at 18:04

AER errors

The command sudo grep -i AER /var/log/syslog* shows us that you're getting a ton of AER (Advanced Error Reporting) errors against PCI device 1d.3.

Your 1d.3 device is your...

1d.3-[05]----00.0  Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

One workaround is to modify /etc/default/grub, find the line near the top that contains "quiet splash" and change it to "quiet splash pci=noaer" and then sudo update-grub. BUT, I don't recommend this if you've got a lot of errors, as all it does is to mask the errors from being reported. The errors still occur.

A better solution is to review /var/log/syslog*, and determine what's wrong with that device. In the case of PCI comm gear, sometimes there's a firmware problem that needs to be resolved, with updated firmware, or some other real fix.


You have BIOS F.25. A newer BIOS exists that may resolve this problem. I can't give you the new BIOS version, as the HP web site requires the serial # of your computer. With that information, you've already been to the HP web site and viewed the new information. For any BIOS update, make sure you have good data backups before performing the BIOS update.

BIOS F.53 is available for download here.

  • Thanks a lot. I added pcie_aspm=off and it solved the issue (atleast on the surface). Accepting your solution and just leaving this incase anyone else ends up here. Once again, Thank you. – Rahul Iyer May 26 '20 at 20:08
  • @RahulIyer As I mentioned in a comment, above, do the BIOS update and see if that takes care of the AER errors. Much better than a patch to hide the errors. – heynnema May 26 '20 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.