1

I have a laptop Assus TUF A17 FA706IU-H7101, nvidia card Ubuntu 20.04 installed. In additional drivers nvidia-driver-440 selected.

All looks good aside i cannot change the screen dim levels. If i use dim keys or the settings menu there is no change.

Also the nvidia settings app opens but has no widgets in it: nvidia-settings ERROR: An internal driver error occurred ERROR: Unable to load info from any available system

Output of xrandr: xrandr: Failed to get size of gamma for output default Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080 default connected primary 1920x1080+0+0 0mm x 0mm 1920x1080 77.00*

I already looked everywhere for a solution, no luck so far. This is really annoying as i cant work/look for more then an hour in the laptop because of the brightness.

Anyone has a workaround for this ?

Thank you

  • 1
    Does this work for you ? "sudo su ; echo 1000 > /sys/class/backlight/your_backlight_device_name/brightness " – Parsa Mousavi May 26 at 11:00
  • For me it's between the range 0 and 4882. – Parsa Mousavi May 26 at 11:02
  • I think the problem is that the kernel cannot use mode-setting of your driver. Can you adjust the gamma or resolution or orientation of your screen ? – Parsa Mousavi May 26 at 11:05
  • And if not , consider switching temporarily to another GPU or install another driver. – Parsa Mousavi May 26 at 11:06
  • That command didnt do anything , max_brigthness is 49 on a file in that folder. How can i switch to another GPU ? – Aiaf May 26 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.