I've just installed ubuntu 20.04 on a macbook pro 3,1. It has an SSD and BIOS boot partition rather than EFI (so I can load the NVIDIA drivers). I have no external USB devices attached.

On shutdown, I keep getting the error:

[12549.497192] hub 6-0:1.0: hub_ext_port_status failed (err = -110)
[12550.557073] Kernal panic - not syncing: Timeout: Not all CPUs entered broadcast exception handler. 

Any ideas anyone?

Thanks in advance!

1 Answer 1


Lots of people with lower versions of ubuntu, different hardware architectures and different specific error messages (although all to do with USB) have reported that switching off and removing the power solved the problem.

Somewhat unbelievingly I tried the trick and it has worked. In my case this meant disconnecting the power cable and pulling the battery out which on my mac is fortunately external.

I've been running for a couple of days now (touch wood) with clean shutdowns and clean boots.

No idea why...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.