2

I habe a driver for my ELM 327 an it uses the pl2303 module which depends on the usbserial and this again depends on the pl2303 module.

What I tried:

sudo modprobe -r usbserial pl2303
sudo modprobe -r pl2303 usbserial
sudo modprobe -rf usbserial
sudo modprobe -rf pl2303
sudo rmmod --force pl2303
sudo rmmod --force usbserial

result of rmmod:

rmmod: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'usbserial': Resource temporarily unavailable
rmmod: ERROR: could not remove module usbserial: Resource temporarily unavailable

result of modprobe:

modprobe: FATAL: Module usbserial is in use.

Also I tried it with the drivers loaded and unloaded.

kernel modules reference each other[1]

OS: Ubuntu 20.04

  • 1
    To start with, which Linux distro have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, Mint, et al.), & which release number? Different releases have different tools for us to recommend. Please click edit & add that to your question, so all facts we need are in the question. Please don't use Add Comment, since that's our one-way channel to you. All facts about your PC should go in the Question with edit as this is a Q&A site, not a general forum, so things work differently here. – K7AAY May 26 at 17:11
  • Some additional reading on pl2303: EP-44 serial printer via USB adapter: Linux – WinEunuuchs2Unix May 31 at 20:03
1

It's possible to blacklist kernel modules.

Checkout this post about How to blacklist kernel modules?

| improve this answer | |
  • Although you answered your own question, I'm upvoting to help you recover lost bounty points. – WinEunuuchs2Unix May 31 at 20:17
0

When you look into dmesg do you see a line where the device was detected when it was plugged in? Ubuntu should have FTDI support out of the box. Normally you would just access it by typing screen /dev/ttyUSB# 38400.

| improve this answer | |
  • Thank you for the response. But I don't want to connect to like that. I just need to unload it from the kernel. – Noel Schenk May 29 at 12:51
  • You could try blacklisting it by editing /etc/modprobe.d/blacklist and adding blacklist driver-name. Maybe that will work for you. – ognjen May 29 at 15:10
0

As OP mentioned rather than unloading module it is easier to not load it in the first place. This is accomplished by blacklisting the module:

To summarize answers in link:

Just open your /etc/modprobe.d/blacklist.conf file and add drivername using following syntax:

blacklist pl2303

Save the file and Reboot. The offending module will no longer be loaded at startup.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.