0

Up until this morning my new installation of Ubuntu 20.04 LTS was working just fine. Then all of a sudden networking stopped working. I first noticed that my chrome browser wasn't working properly. Then testing with curl www.google.com showed that network was unreachable. This was further confirmed with ping www.google.com.

I tried to see what was wrong by clicking on the drop down menu at top right of the screen where networking options are usually visible to see that no networking options were visible. I then tried searching for settings in the applications search bar to see that settings application was no longer visible. Do I have some strange new virus or something? How do I get networking back up and running?

Output of ip a:

...
2:enp3s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether c4:65:16:24:d5:9a brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ec:5c:68:2a:f1:51 brd ff:ff:ff:ff:ff:ff

So both the ethernet and wireless have no IP set.

Output of ip route is completely blank so no routing information is set as far as I can see.

3
  • Please add ip a command output by editing your original question. May 25 '20 at 15:31
  • Do you have physical switch for WiFi?
    – koni_raid
    May 25 '20 at 15:32
  • @FedonKadifeli I added some outputs for you.
    – James Read
    May 25 '20 at 15:41
1

This is how I solved the problem:

First I got networking back up with:

sudo ip address add 192.168.1.4/24 dev enp3s0
sudo ip link set enp3s0 up
sudo ip route add default via 192.168.1.254

With networking now working I was able to reinstall the settings application as follows:

sudo apt-get install gnome-control-center

Everything went back to normal. I rebooted and networking was still working. My settings application was findable and launchable and the dropdown menu at the top right now included network settings once again.

It remains a mystery what caused all this though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.