0

I just updated my dual boot Lenovo T510 18.04 Ubuntu to 20.04 using a graphical guided wizard, based on instructions from this official guide https://ubuntu.com/blog/how-to-upgrade-from-ubuntu-18-04-lts-to-20-04-lts-today

Everything seemed to go well, but after first boot Ubuntu never started. The new ubuntu loading icon became shortly visible, disappeared soon, and after that only blank screen was visible and mouse cursor, which was at times even movable, but anyway, there was nothing I was able to do there. I tried a couple of reboots but no luck.

Next I tried to start ubuntu using recovery mode. I never used recovery mode before, so the options were not too familiar to me, so I just selected the topmost option, falling back to regular boot, but according to the popup-text, with one difference: without loading some graphical drivers. And for my stunning luck, this seemed to be the only reason why regular boot was not working: after doing regular boot via recovery mode ubuntu started! So now I was pretty much 100% sure that the problem was with the graphic drivers despite having absolutely no clue or lead what might have been the problem before this.

I continued investigations related to graphic drivers and realized first that my set was the following: NVIDIA GT218M [NVS 3100M]

According to Ubuntu 20.4 Software & updates center, the recommended driver for me was following: nvidia-340

It seemed like I did not have this one installed, but the system was using x.Org X server - Nouveau display driver. I did not have any reason not to believe what shining new Ubuntu 20.4 was recommending to me, so what I did was just that I selected the recommended driver and installed it. After installation, everything seemed to work as they were before installation but I wanted to reboot the system anyway.

After reboot things went from bad to worse: now I'm not even able to get ubuntu started using my previously described method of starting the regular ubuntu boot from recovery mode.

I tried to set nomodeset during Ubuntu start, but this did not help either - seemed like every reboot with and after this was slightly different, but in the end, system stalled or even totally shuts down before the desktop should have become visible.

Would anyone here know where should I look from here?

  • When your "Ubuntu never started" try go to cmd mode using Ctrl + Alt + F2. Then login with your user. Then type in commandline comand startx and find errors. – mature May 25 at 14:49
  • Do you still see the GRUB menu? Are you able to get to Recovery Mode? Can you boot to a Ubuntu Live DVD/USB? Start comments to me with @heynnema or I'll miss them. – heynnema May 25 at 14:58
  • thanks @mature I will try ctrl+alt+f2 and start digging deeper. – Vka May 25 at 15:01
  • thanks @heynnema yes, I can see GRUB menu and I can see the recover mode options too. I don't have ubuntu live DVD/USB and actually my laptop's dvd player is broken too - anway, I see no reason why I could not create ubuntu usb using windows - my 2nd option in dual boot setup. – Vka May 25 at 15:01
  • @Vka You can also try remove any NVIDIA proprietary driver: sflash.biz/askubuntu/… Then when you will get back to gnome shell GUI again install it. – mature May 25 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.