0

I have just a windows font file in /usr/share/fonts and was rebooting to check if it was okay, and surprise, Ubuntu 20.04 can't boot.

I have this screen:

enter image description here

There's a mouse pointer, but nothing to log in and it stays that way

I cannot access to any console by Ctrl Alt FX, I have restarted used advanced grub optios to use the recovery boot, I can there access to the command line, i've deleted the font file i've added, but this had zero effet, I still can't boot, and I don't see any errors.

  • Since you have the mouse pointer , it's probably the gdm that shows that message. A possible solution is to install another display manager like sddm via "sudo apt install sddm" since you have access to the console.Check that out to see if that can solve the problem. – Parsa Mousavi May 25 at 13:41
  • With sddm it shows the login screen, but without any fonts, I had been able to type my password, and it logs in into Gnome, there's definitely somthing wrong with the fonts, how can I reset all the font folder to the state it's right after a new install? – limmt May 25 at 13:56
  • Each sddm theme has a file named theme.conf which contains a line "Font= ... " . In that line you can change the font.I couldn't find any settings regarding the font in the gdm files. It's a bit ridiculous but you can download a theme for sddm from here and extract the files to the directory "/usr/share/sddm/themes/" and just change line beginning with "Font" in the theme.conf. – Parsa Mousavi May 25 at 14:07
  • I have checked the font manager, I only have three fonts installed, fonts that I use for some documents. There are zero system fonts installed. How can I install them back? I've just removed and reinstalled msttcorefonts, but te font don't appear anywhere. The fonts are in the /usr/share/fonts/ folder, but the system cannot find them – limmt May 25 at 14:14
  • " sudo apt install '?name(ttf.*)' " will install lots of true-type fonts for you but if you want all the default ubuntu fonts , you can take them back from an ubuntu live image . Copy all the fonts in the ubuntu iso to your /usr/share/fonts/ directory and then run fc-cache -f -v to update your font cache. – Parsa Mousavi May 25 at 14:19
0

Installing an other display manager (sddm) in recovery mode allowed me to log in. It was a rights problem on the fonts.

A chmod to 755 to all the fonts and rebooting the system solved the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.