it used to be that tapping two fingers on the touchpad send a middle mouse click. Now it does a right click and three fingers now are the middle click. I really can't understand the change and think it is a bug or badly copied from Apple or something. The reasoning escapes me totally. I use middle click to open links in a new tab in the browser all day and I rarely use right click (and I have a right mouse button below the touchpad, doh) Tapping three fingers on my tiny EeePC touchpad is next to impossible so I want the old behavior. I found:

synclient TapButtons2=2
synclient TapButtons3=3

but that did not work on 10.10

Does anyone know how to restore sane behavior?

  • 1
    Should be TapButton2=2, etc., without the 's'. Commented May 30, 2012 at 5:56

13 Answers 13


The default settings that seem to be enabled with "tap to click" (on my laptop anyway) also provides the following functionality:

  • Middle Click (tap at top right of scroll area)
  • Right Click (tap at bottom right of scroll area)
  • 1
    That's awesome. And it's working by default I never knew about it. Thank you. Great answer! Commented Aug 21, 2012 at 14:06
  • Works great, really hard one to guess. Commented Sep 10, 2012 at 18:12
  • This is not working if you enable "Two-finder scrolling". Two bad, because I like it more then "Edge scrolling".
    – Radu Maris
    Commented Mar 7, 2013 at 19:55
  • Perfect it also works for ubuntu 18.04 with my new dell precision 5530
    – Max
    Commented May 1, 2019 at 15:16

The following solution has been tested on Ubuntu 12.04 and 12.10. It works perfectly.

  1. Create a file /etc/X11/xorg.conf.d/touchpad.conf with the following content:

    Section "InputClass"
            Identifier      "Touchpad"                      # required
            MatchIsTouchpad "on"                           # required
            Driver          "synaptics"                     # required
            Option          "MinSpeed"              "0.5"
            Option          "MaxSpeed"              "1.0"
            Option          "AccelFactor"           "0.075"
            Option          "TapButton1"            "1"
            Option          "TapButton2"            "2"     # multitouch
            Option          "TapButton3"            "3"     # multitouch
            Option          "VertTwoFingerScroll"   "1"     # multitouch
            Option          "HorizTwoFingerScroll"  "1"     # multitouch
            Option          "VertEdgeScroll"        "1"
            Option          "CoastingSpeed"         "8"
            Option          "CornerCoasting"        "1"
            Option          "CircularScrolling"     "1"
            Option          "CircScrollTrigger"     "7"
            Option          "EdgeMotionUseAlways"   "1"
            Option          "LBCornerButton"        "8"     # browser "back" btn
            Option          "RBCornerButton"        "9"     # browser "forward" btn
  2. Run dconf-editor from your user (don't sudo). Go to org.gnome.settings-daemon.plugins.mouse, uncheck active. (It is a known issue that Gnome's Settings Daemon may override your xorg.conf settings).

  3. Log out and log in. Things should be working fine now.


You may also be interested in installing the gpointing-device-settings package, which will provide more configuration options for your touchpad. BTW, in Ubuntu 10.04LTS+ this replaces gsynaptics.

sudo apt-get install gpointing-device-settings

Once installed you find it under System -> Preferences -> Pointing Devices.


xinput gave:

unable to find device SynPS/2 Synaptics TouchPad

so I did

synclient TapButton3=3 TapButton2=2

from a tip from http://ubuntuforums.org/showthread.php?t=1251372

I put this in my ~/.bashrc and things seem to work


To fix the middle click you can use the following command:

xinput set-int-prop NN 266 8 2 3 0 0 1 2 3

Where NN is the id of the mousepad device, you can see it with the command xinput list. 266 is the id of the property "Synaptics Tap Action" you can see it with xinput list-props NN

You have to run this command every time you boot/login/wake.

To make it permanent you can put this command to the end of your .profile file in your home folder. (You can also try to put it in /etc/init.d/rc.local, but in my case it didn't work.)

  • this is dangerous, please consider changing "266" to "PP" or so - the property number (266) is device dependent
    – IljaBek
    Commented Dec 5, 2015 at 1:07

To preserve your synaptics configuration after resume, I followed this steps from wiki.archlinux.org:

Gnome settings daemon may override existing settings (for example ones set in xorg.conf.d) for which there is no equivalent in any of the graphical configuration utilities. It is possible to stop gnome from touching mouse settings at all:

1. Run dconf-editor
2. Edit /org/gnome/settings-daemon/plugins/mouse/
3. Uncheck the active setting 

It will now respect your system's existing synaptics configuration.

It worked on Ubuntu 11.10 AND now I have:

  • Two-finger scrolling.
  • Middle Click with two fingers tap.
  • Right Click (tap at bottom right of scroll area).

Try running this as a script

xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Tap Action" 8, 9, 0, 0, 1, 2, 3  # pad corners rt rb lt lb tap fingers 1 2 3 (can't simulate more then 2 tap fingers AFAIK) - values: 0=disable 1=left 2=middle 3=right etc. (in FF 8=back 9=forward)
  • unable to find device SynPS/2 Synaptics TouchPad
    – Thomas A.
    Commented Nov 11, 2010 at 0:49
  • xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Tap Action" 8, 9, 0, 0, 1, 2, 3 works!
    – Thomas A.
    Commented Nov 14, 2010 at 23:40


I now have to run

xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Tap Action" 8, 9, 0, 0, 1, 2, 3


gconftool-2 --set --type=bool /apps/gnome-power-manager/lock/suspend false 

to restore things to something I can tolerate, BUT I have to run those commands after each resume. Which script is run after each resume to automate that?

  • /etc/pm/sleep.d/99-test.sh works for me
    – Thomas A.
    Commented Nov 22, 2010 at 7:01
  • hmmm, it works for resume with out password but not for making double tap work
    – Thomas A.
    Commented Nov 22, 2010 at 8:19
  • 2
    why is thid so hard?
    – Thomas A.
    Commented Nov 22, 2010 at 8:20

Add this to /etc/X11/xorg.conf:

Section "InputClass"
    Identifier "middle button emulation class"
    MatchIsPointer "on"
    Option "Emulate3Buttons" "on"

WARNING: try with caution. When added to ~50-synaptics.conf in 11.10, may cause boot hang after login screen.


Solution #1

I just discovered that if you keep two fingers pressed on touchpad and press the left click "button" of the touchpad it emulates the middle mouse button (so you need 3 fingers in total)

Solution #2

If you still want to click both buttons and produce a middle button emulation, execute:

synclient EmulateMidButtonTime=100

EmulateMidButtonTime allows you to change the time required to produce a middle button (allowed time period to click both buttons). 100 means 100 milliseconds (ms).

You may set it to even higher values, such as synclient EmulateMidButtonTime=500 for 500ms, which is enough time to click both buttons


I did exactly what Nikita Volkov said (creating xorg.conf.d folder and touchpad.conf file), but my file looks like this:

Section "InputClass"
    Identifier      "Touchpad"                      # required
    MatchIsTouchpad "on"                            # required
    Driver          "synaptics"                     # required
    Option          "MinSpeed"              "0.5"
    Option          "MaxSpeed"              "1.0"
    Option          "AccelFactor"           "0.075"
    Option          "TapButton1"            "1"
    Option          "TapButton2"            "2"     # multitouch
    Option          "TapButton3"            "3"     # multitouch
    Option          "VertTwoFingerScroll"   "1"     # multitouch
    Option          "HorizTwoFingerScroll"  "0"     # multitouch
    Option          "MaxTapTime"            "70"
    Option          "FastTaps"              "1"

and now it's perfect!


For me I lost two fingered right click after installing gnome. I tried several of these answers and this is what finally worked:

Try this:

xinput --set-prop "SynPS/2 Synaptics TouchPad" --type=int "libinput Click Method Enabled" 0 1

If it works, make it persist across reboots by adding it as a startup script. Search for Startup Application Preferences. Add a new Startup Program, and in command, paste the line from above.

enter image description here

Note: I previously tried adding it to /etc/X11/Xsession.d/ at first but that didn't work for me (gnome, ubuntu 16.10).

synclient TapButton2=3 TapButton3=2

key named according to number of fingers, value indicates mouse button number.

  • 3
    Sorry, my original comment wasn't very useful. I confused this with a totally separate post. I apologize. Let me start again: If this method (which does not contain a typo, though the original question here does) is different from the method that the original question said does not work, you should edit this answer to explain how it is different. That is probably why this answer was downvoted. You should also edit this answer to explain what needs to be done in complete sentences, and to make clear what parts of your answer are commands and what parts are the explanation. Commented May 30, 2012 at 7:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .