1

I am trying to get the huawei 4g Dongle to work on my jetson nano in order to provide network for me. NVIDIA Jetson TX1 L4T 32.3.1 [ JetPack 4.3 ] Ubuntu 18.04.4 LTS Kernel Version: 4.9.140-tegra CUDA 10.0.326 this is my L4T and kernel version. Firstly, clone the BuildKernelAndModules in the Jetsonhacks Nano repository in github, https://github.com/JetsonHacksNano/buildKernelAndModules

git clone https://github.com/JetsonHacksNano/buildKernelAndModules

Open the folder where it is downloaded, it should be in your home directory. Once you located your buildKernelAndModules folder, run the following codes 1. ./getKernelSources.sh 2. ./makeKernel.sh 3. ./makeModules.sh 4. ./copyImage.sh These steps will take awhile(especially the makeKernel and makeModules scripts) Once everything is downloaded, run the ./editConfig.sh

In the config settings,

Enable these following settings : Device Drivers ---> [] Network device support ---> [] PPP (point-to-point protocol) support -- PPP [M] PPP BSD-Compress compression -- PPP_BSDCOMP [M] PPP Deflate compression -- PPP_DEFLATE [M] PPP MPPE compression (encryption) -- PPP_MPPE [M] PPP over Ethernet - PPPOE [] PPP support for async serial ports -- PPP_ASYNC [M] PPP support for sync tty ports -- PPP_SYNC_TTY [] USB support ---> <> USB Serial Converter support ---> [] USB Serial Console device support -- USB_SERIAL_CONSOLE [] USB Generic Serial Driver -- USB_SERIAL_GENERIC [] USB driver for GSM and CDMA modems -- USB_SERIAL_OPTION The * means it is built as a kernel, the M denotes it is built as a Module.

To enable these in the config file, type ‘y’ to enable it as a kernel, ‘m’ to enable it as a module.

Once this is done, save and exit the file.

Run ./makeKernel.sh and ./makeModules.sh to build the new kernels. Run ./copyImage.sh to copy the image to the boot folder. Reboot the jetson by:

Sudo reboot now

I Could successfully enable the 4g dongle but need to configure the APN for the dongle. Then i proceeded withInstall ModemManager and NetworkManager by running these 2 codes : sudo apt-get install modemmanager sudo apt-get install network-manager

Run lsusb to check if the dongle is connected You should see this : 12d1:1506 Huawei Technologies

Once you confirmed that the dongle is connected, run mmcli -L to see if it is detected as a modem.If they mentioned “modemmanager process in the bus unavailable”, you have to enable ModemManager as a service and start it on boot:

sudo systemctl enable ModemManager sudo systemctl start ModemManager

Run mmcli -L again and you should have detected a modem with a number at the end.

Run mmcli -L x (replace x with the number of the modem) This will show you the full modem settings.

Check whether the dongle is configured and to confirm whether the device is detected: nmcli d

Next type this in the Terminal : nmcli c add type gsm ifname ttyUSB0 con-name sandbox_lte apn e-ideas ipv4.dns “8.8.8.8,8.8.4.4” i am using e-ideas because this is from singtel Then i Type these into the Terminal:

nmcli c edit sandbox_lte goto ipv4 set dns 8.8.8.8, 8.8.4.4 verify save

Activate

But after i run nmcli d

ttyUSB0 gsm connecting (prepare) sandbox_lte

It shows it was still connecting and the internet logo on right hand top was forever connecting.

If anyone happens to know please help! thanks

0

I'm trying to do the same as you,I mean trying to configure the huawei e3372 4g dongle with a SIM inserted inside to connect the nano to internet using the mobile connection. Below you can see what happens in my case :

root@ziomario-desktop:~# lsusb

Bus 001 Device 012: ID 12d1:14dc Huawei Technologies Co., Ltd.

root@ziomario-desktop:~# mmcli -L No modems were found

root@ziomario-desktop:~# sudo systemctl enable ModemManager sudo systemctl start ModemManager Failed to enable unit: Unit file /lib/systemd/system/sudo.service is masked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.