5

Lock screen does not work on Ubuntu after upgrade to 20.04. I have it turned on in tweaks and it does not work. When I click "lock" the screen simply reloads and disables some extensions in the process. It does not work at all. How can I fix this?

ls -al ~/.local/share/gnome-shell/extensions:

total 80
drwxrwxr-x 20 me me 4096 May 10 09:32 .
drwx------  3 me me 4096 May 25 15:58 ..
drwxrwxr-x  4 me me 4096 Jun  6  2019 [email protected]
drwxr-xr-x  3 me me 4096 Mar 14 07:08 [email protected]
drwxrwxr-x  3 me me 4096 May 10 09:30 [email protected]
drwxr-xr-x  4 me me 4096 Dec 12 14:55 [email protected]
drwxrwxr-x  4 me me 4096 Jun  7  2019 [email protected]
drwxrwxr-x  3 me me 4096 May  9 22:17 [email protected]
drwxrwxr-x  4 me me 4096 May  9 22:13 [email protected]
drwxr-xr-x  5 me me 4096 Apr 29 16:20 [email protected]
drwxrwxr-x  3 me me 4096 May 10 09:31 [email protected]
drwxrwxr-x  3 me me 4096 Apr 21  2019 fq@megh
drwxrwxr-x  3 me me 4096 May 10 09:30 [email protected]
drwxrwxr-x  3 me me 4096 May  9 22:14 [email protected]
drwxrwxr-x  3 me me 4096 May 10 09:31 [email protected]
drwxr-xr-x  2 me me 4096 Nov 28 12:00 removeaccesibility@lomegor
drwxrwxr-x  4 me me 4096 May  9 22:14 screenshot-window-sizer@gnome-shell-extensions.gcampax.github.com
drwxrwxr-x  4 me me 4096 May  9 22:15 [email protected]
drwxrwxr-x  3 me me 4096 May  9 22:15 [email protected]
drwxrwxr-x  3 me me 4096 May 10 09:32 [email protected]

ls -al /usr/share/gnome-shell/extensions:

total 68
drwxr-xr-x 17 root root 4096 Oct 29  2019 .
drwxr-xr-x  7 root root 4096 May 23 10:13 ..
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 desktop-icons@csoriano
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 native-window-placement@gnome-shell-extensions.gcampax.github.com
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 screenshot-window-sizer@gnome-shell-extensions.gcampax.github.com
drwxr-xr-x  3 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  3 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  2 root root 4096 May  9 18:04 [email protected]
4
  • 1
    Edit your question and show me ls -al ~/.local/share/gnome-shell/extensions and ls -al /usr/share/gnome-shell/extensions. Start comments to me with @heynnema or I'll miss them.
    – heynnema
    Commented May 25, 2020 at 15:09
  • Thank you for your reply. I added the info you asked for as a screenshot cuz I couldn't figure out how to make this respect newlines. It kept sticking everything together - both in "blockquote" and "code".
    – i9pp0
    Commented May 25, 2020 at 15:35
  • 1
    To copy/paste the output of my commands, copy the output to the clipboard, edit your question, paste in the clipboard, select the pasted text, then click the {} icon to format it. Please see my partial answer. Do it and report back. Please remember to start comments to me with @heynnema.
    – heynnema
    Commented May 25, 2020 at 15:53
  • @heynnema Thanks for the help. I just saw this after the answer so comment there is not editing to add your name.
    – i9pp0
    Commented May 25, 2020 at 16:02

1 Answer 1

6

Holy !@#$% batman! You've got WAY too many GNOME Shell extensions, and many of them overlap in functionality.

First step...

Go to https://extensions.gnome.org/local/ and disable ALL extensions, then restart GNOME Shell with ALT+F2, then r, then ENTER. Then retest the lock screen, and see if it works normally.

Second step...

Let's start by cleaning out your /usr/share/gnome-shell/extensions...

sudo rm -r /usr/share/gnome-shell/extensions/*gcampax.github.com

Restart the GNOME Shell using the previous instructions.

This should leave you with these extensions in /usr/share/gnome-shell/extensions...

drwxr-xr-x  2 root root 4096 May  9 18:04 desktop-icons@csoriano
drwxr-xr-x  3 root root 4096 May  9 18:04 [email protected]
drwxr-xr-x  3 root root 4096 May  9 18:04 [email protected]

Using the same web location that I gave earlier, REMOVE any remaining extensions that you either 1) don't really need, or 2) overlap in functionality. Then re-enable the remaining extensions one-at-a-time to see if one of them causes your lock screen problem. Restart the GNOME Shell after each disable/enable/remove(s) change.

7
  • You are correct....Robin :) it works now. I saw 68 and 80 in the readout of what you asked for, but I only have 24 extensions (showing in tweaks) and about a third are disabled. I guess I should re-enable one by one now and test where the problem is, right?
    – i9pp0
    Commented May 25, 2020 at 15:58
  • 1
    @i9pp0 Please see the Second Step in my answer.
    – heynnema
    Commented May 25, 2020 at 16:04
  • I did what you said, and then re-enabled the extensions I want. Everything works correctly now. Thank you for your help. I will do some testing to find out which ones were conflicting.
    – i9pp0
    Commented May 25, 2020 at 16:14
  • Aaaaaaaa I forgot your name again....and it won't let me add it - again!
    – i9pp0
    Commented May 25, 2020 at 16:15
  • 1
    @i9pp0 Also, to see if extension are still causing problems, do grep -i stack /var/log/syslog*, and any "Stack trace" errors from gnome-shell are probably bad extension errors.
    – heynnema
    Commented May 25, 2020 at 16:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .