2

I recently upgraded from Ubuntu 19.10 to 20.04. I experience the following problem. The graphics is slightly delayed every second or so. This can be seen in at least three ways.

  1. Video playback where the video freezes for a noticeable amount every few seconds.
  2. When scrolling in a document or a webpage, where the graphics suddenly jumps.
  3. When writing text like this, the text will also appear in noticeable spurts.

I have a Lenovo Yoga X1 (4th gen) with a 4K screen (3840 x 2160).

These effects where not present while using Ubuntu 19.10.

Might be related to this issue: Choppy Video playback on Ubuntu 20.04

$ lspci -v | grep -i vga -A 12
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake) (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Lenovo UHD Graphics 620 (Whiskey Lake)
    Flags: bus master, fast devsel, latency 0, IRQ 150
    Memory at e9000000 (64-bit, non-prefetchable) [size=16M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 2000 [size=64]
    Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0c)
    Subsystem: Lenovo Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem
0

It seems that the problem might not be related to the graphics driver.

I did the following. I tried selecting Ubuntu on Wayland when logging in. This did not change the problem.

I have 5 options when logging in to my machine:

  1. Gnome (no problem)
  2. Gnome on Xorg (no problem)
  3. Ubuntu (problem)
  4. Ubuntu on Wayland (problem)
  5. Unity (problem)

Similar to the two options displayed in the picture below (from: https://linuxconfig.org/how-to-enable-disable-wayland-on-ubuntu-20-04-desktop) enter image description here

I think I have selected to install Gnome manually earlier, but I am not completely sure. I first tried with Ubuntu on Wayland, but this did not solve my problem. But running Gnome (which is Wayland in the default option) seems to fix the problem. If you do not have Gnome installed I think you can follow this guide:

https://www.wikihow.com/Install-Gnome-on-Ubuntu https://www.wikihow.com/Install-Gnome-on-Ubuntu

| improve this answer | |
  • The problem seems to have been solved with the latest update to Ubuntu. 4.0-40-generic #44-Ubuntu – Ulrik Nyman Jul 6 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.