I have a laptop with Ubuntu 20.04. I can connect to my main WIFI signal, but cannot connect to TP Link WiFi extender. The same laptop with Windows 10 (dual boot) works fine. Other devices like tablets, ipads or phones are connected to this extender normally. Only in Ubuntu 20.04 is the problem. Thanks in advance for any suggestion.

  • I had many issues connecting Ubuntu 20.04 to TP-Link devices. The only way I could fix it was by updating my kernel to 5.6. Now everything is working fine. – Rafael May 24 at 23:31
  • Do you have WPA2/AES enabled for the wireless network in your TP-Link, and in your router? Do you have wpasupplicant installed in Ubuntu? – heynnema May 24 at 23:53
  • I'm new in GNU/Linux, I've a WPA2/AES password in my main router and other in my TPlink extender (the extender have other network name). I don't know what is wpasupplicant. I just installed ubuntu 20.04 and its updates via software updates panel. – Martin Lopez Funes May 26 at 15:06
  • I've updated to kernel 5.6.14 and the problem was not fixed. – Martin Lopez Funes May 26 at 22:47
  • I am sad to hear that updating your kernel did not fix the problem. Would you mind describing in more details what kind of error you experience when you try to connect to the TP Link WiFi Extender? – Rafael May 27 at 18:40

Today I faced a similar problem after switching over to Linux from Windows 10. Windows, my phone, consoles, etc were all able to connect to my TP-Link extender, but my Linux installation couldn't. I found your thread and was dismayed to find it had no solution, but as I managed to fix the problem for myself, I thought I'd post what worked for me here.

After a while of searching, I decided to try changing the DHCP client. I installed the package dhcpd5 from the repositories and then used a text editor to open the file /etc/NetworkManager/NetworkManager.conf.

Underneath the header [main], I added the line dhcp=dhcpd.

I ran sudo systemctl stop NetworkManager.service, then sudo systemctl start NetworkManager.service. I was then able to connect, and a speed test indicates the WiFi network is working properly.

Hope this helps!

| improve this answer | |

I also faced the same problem. In my case, the previous solution didn't work (installing dhcpd5 and adding the line in NetworkManager.conf).

On top of that, I did apply the steps suggested in this link (which ironically seems to get info from AskUbuntu) and that worked. I copy the steps here just in case they help somebody else:

git clone https://github.com/cilynx/rtl88x2bu.git
cd rtl88x2bu
VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.