8

I have Kubuntu 20.04 LTS version. I have two monitors connected to my PC - primary one via HDMI and secondary via DisplayPort. Both have the same resolution. After login into KDE I have the 'task panel' and the 'application launcher' on the correct (primary) monitor. But sometimes I dont have any 'desktop' - just black screen (when I minize all windows) on the primary monitor. I have correct desktop wallpaper on the secondary monitor - but of course, without any widgets since they are placed on the primary one. I don't know exact steps to reproduce, because it seems this is happening randomly - sometimes I have the desktop wallpaper and sometimes i don't. In all cases I have wallpaper on secondary monitor and I have the 'main panel' and 'application launcer' visible on the primary one (but not the other widgets, icons and wallpaper) This happens on different activities too - for some I have the desktop layout as Desktop and for other I have it as Folder View Any idea what can couse this and/or how to fix it?

Thanks

4 Answers 4

7

I have to use the following command from terminal:

kquitapp5 plasmashell && kstart5 plasmashell &

but yes I am also looking for solution to make it start automatically as in single display.

2
  • Worked well for me. Maybe better using nohup to let one closing the terminal while keeping plasma running : nohup kstart5 plasmashell
    – Virtual
    Feb 16 at 17:06
  • Thanks. Problem happens to me from time to time, quite randomly. Your workaround is good! Solves the problem on my Kubuntu 20.04 machine as well (KDE Plasma 5.18.5). While we wait for a proper fix to a potential bug that causes this, I will use this solution (through an alias)!
    – protonic
    Jun 7 at 6:37
1

I have had the same problem. Kubuntu 20.04 LTS, Primary monitor HDMI-1, Secondary VGA-1. In System Settings...Hardware, Display and Monitor...Display Configuration I found disabling/enabling and switching primary display eventually brought the desktop back but the taskbar/panel ended up on the secondary monitor. Right clicking the primary desktop...Add panel...default panel brought installed a new task bar on the primary monitor leaving a duplicate on the second. Right clicking on the secondary panel...Edit Panel...Remove panel...X to close edit returned everything to normality.

This is a workaround, not a fix.

1

A semi permanent workaround for this is to add an autostart script into that waits for plasmashell to start after login, then restarts it. You can add the script in Settings>Startup and Shutdown>Autostart

Here's an example script that should do the trick.

#!/usr/bin/bash

# spin wait for plasmashell to start
while [ ! pgrep plasmashell ]; do
    wait 1
done

# wait for plasmashell to fully load before restart, may need to be adjusted
# based on how fast plasma loads on your system
wait 5

kquitapp5 plasmashell && kstart5 plasmashell 

0

Having same issue. I can confirm toggling monitor position and primary display made it work again.

2
  • 3
    It would be helpful if you would edit your question to explain exactly how you did this. What steps would someone else need to follow to apply your solution?
    – Nmath
    Oct 27, 2020 at 0:34
  • Just random fiddling with the display settings did the job for me.
    – dremodaris
    Jun 7, 2021 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.