I have a Lenovo g50-70 with Intel i3 4th Gen, Intel HD Graphics 4400, 8 GB RAM and a 1TB HDD. I installed Ubuntu 20.04 recently, and the installation and the first boot up went fine. But afterwards, whenever I boot the computer from a shut down state, the screen stays black. It does not show any vendor logo or errors. If I force shut down the computer and then power on, the computer starts normally. I have tried installing other distros like elementary OS, Manjaro etc., but the problem remains the same. What could be the problem, and how to solve it?

5 Answers 5


From what I can gather, it could be a few different bugs. Please read and follow the instructions. I listed them in descending order from easiest to hardest.

1. Updates

Problem: If there's ever an issue, by habit, updating and upgrading might help it, especially with new releases having bugs.

solution: Run in your terminal. autoremove will remove any unused packages files. Might be an incompatibility issue with 20.04 that you weren't even aware of.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoremove

2. GRUB bootloader

Problem: the GRUB boot loader may have been overwritten (MBP), preventing Ubuntu from booting

Solution: check is whether you can access the GRUB2 boot loader. Boot your computer while holding the Shift key. If you see a menu with a list of operating systems appear, you’ve accessed the GRUB boot loader.

If you see the Grub boot menu: Select the “Advanced options for Ubuntu” then select the “Ubuntu (recovery mode)” option. Checkout the 1st URL in the appendix for which menu option to use.

If you don't see the Grub boot menu: Make sure you have working wifi then following below.

  1. If you have the media you installed Ubuntu from, insert it into your computer, restart, and boot from the removable drive. If you don't, download a Ubuntu live CD and burn it to a disc or create a bootable USB flash drive.

  2. When Ubuntu boots, click "Try Ubuntu" to get a usable desktop environment.

  3. Open a Terminal window from the Dash and run the following commands:

    This will install and launch Boot Repair to scan your system.

    sudo apt-add-repository ppa:yannubuntu/boot-repair  
    sudo apt update  
    sudo apt install -y boot-repair  

    Choose recommended repair and follow the instructions.

  4. Restart your computer. It should boot up normally if that was the issue.

    Note: if you want the original walk-through or another way check out the 2nd URL in the appendix.

3. Reinstall Ubuntu while keeping files and programs

Problem: Might be a problem with Ubuntu 20.04. I currently use 20.04 version without this bug. It might be that it wasn't downloaded properly.

Solution: Follows instructions from the 2nd and 3rd URL in the appendix. From the least aggressive to the most. Follow these terminal commands: to update the snap store to was recently switched.

sudo apt update
// if you don't have it then run: 
sudo apt install gnome-software

to reinstall Ubuntu software -shouldn’t erase your files but if you want, make a backup of your files

sudo apt install --reinstall ubuntu-software

How do I reinstall Ubuntu Software in Ubuntu 20.04 LTS version?

  • Oddly for me booting into linux (recover) from inside Grub boot menu and then just selecting the "resume boot" option fixed the black screen for me. Rebooting worked as normal after that. Nov 22, 2022 at 23:21

I had a similar problem. I seem to have fixed it by changing from lightdm display manager to gdm3 display manager. I did this by using the command sudo dpkg-reconfigure lightdm and following the prompts (using the enter key and the up/down arrow keys.)


This will solve the problem:


sudo setpci -s 00:02.0 F4.B=00


sudo setpci -s 00:02.0 F4.B=00

in the terminal. Then lets edit the file:

gedit ./etc/pm/sleep.d/9_lcd_backlight.sh

(if not gedit then any other text editor) this will create the file 9_lcd_backlight.sh. 9 is the priority you can put any number through 99.

Paste the following in your file.


    case $1 in
        setpci -s 00:02.0 F4.B=0
            echo "oh, suspend to disk is over, we are resuming..."
        setpci -s 00:02.0 F4.B=0
            echo "hey, the suspend to RAM seems to be over..."
        *)  echo "here we GO!."

With the bash file in place you now need to make the file executable. Make sure you are in the directory ./etc/pm/sleep.d/ and type this in the terminal:

chmod +x 9_lcd_backlight.sh

Once the bash file is now executable lets make sure the back-light turns on when you boot up. Input the next 2 lines in ./etc/rc.local file at the bottom line. So type in the terminal:

gedit ./etc/rc.local

This will open rc.local file. Now at the bottom make sure it looks like below and save.

sudo setpci -s 00:02.0 F4.B=00

exit 0

You should be fine, reboot and check it out. Leave a like, comment , thanks.

  • This is the same instructions found in the link that I posted in the previous comment. May 29, 2020 at 6:36

The solution to the problem, in my case, was very simple. In my BIOS, the boot mode was set to legacy. I just changed it to UEFI and turned off the secure boot option. Now the problem is no more!


Full root drive!

Before you throw your hands up and reinstall Ubuntu, check if your kernel disk is out of space. That seems to interfere with full graphical boot (though ssh still works).

Moral of the story: any time you run rsync backup jobs, make sure your destination disk is mounted successfully. You are one unsuccessful mount away from filling your root disk.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .