0

I'm running a Ubuntu Dual Boot (16.04 alongside Windows 10), following this protocol : https://itsfoss.com/install-ubuntu-1404-dual-boot-mode-windows-8-81-uefi/

The initial partitioning is not enormous (Ext 4 Root partition is around 20G, a SWAP file of 8GB, and the Home partition is 40G).

However all my heavy data is store on a second ntfs 2.0 TB Hard disk, device /dev/sda2 mounted as /media/sachahai/DATA

I have several software on Ubuntu that load and store data on this hard disk and everything went fine (more than 80G of file already saved from UBUNTU to this disk).

However, I tried to unzip a 4G folder, containing 40'000 files, and it fails at a point with a 'No Space Left on device' error. And now I canno't even create a new folder or file on the second hard disk and have the same error.

I know this error has been reported several times, but the proposed solutions didn't work for me, and all the inodes and free space looks fine :

df - h

Filesystem      Size  Used Avail Use% Mounted on
udev             32G     0   32G   0% /dev
tmpfs           6.3G  9.6M  6.3G   1% /run
/dev/nvme0n1p7   21G  9.4G  9.7G  50% /
tmpfs            32G   93M   32G   1% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs            32G     0   32G   0% /sys/fs/cgroup
/dev/nvme0n1p1  646M   80M  567M  13% /boot/efi
/dev/nvme0n1p9   34G   15G   18G  47% /home
tmpfs           6.3G   60K  6.3G   1% /run/user/1000
/dev/sda2       1.9T  304G  1.6T  17% /media/sachahai/DATA

df -i

Filesystem         Inodes   IUsed      IFree IUse% Mounted on
udev              8200278     618    8199660    1% /dev
tmpfs             8209580     906    8208674    1% /run
/dev/nvme0n1p7    1343488  285747    1057741   22% /
tmpfs             8209580      99    8209481    1% /dev/shm
tmpfs             8209580       5    8209575    1% /run/lock
tmpfs             8209580      17    8209563    1% /sys/fs/cgroup
/dev/nvme0n1p1          0       0          0     - /boot/efi
/dev/nvme0n1p9    2252800  297462    1955338   14% /home
tmpfs             8209580      31    8209549    1% /run/user/1000
/dev/sda2      1636301572 1453504 1634848068    1% /media/sachahai/DATA

Error when try to create a new folder in /dev/sda2

How can I resolve my problem ? (Freely use the free inodes and space of DATA hard disk from Ubuntu)

And also naive question : If I am on my Ubuntu boot, and I transfer a huge file from an USB stick to my second ntfs hard disk with plenty of space, will that data transit somehow throughout the ext 4 partitioning and need therefore the space here as well ? (Anyway at the moment I can't even create a folder, while having lot of space on both ext 4 and ntfs second hard disk)

Thanks a lot for your help

  • 2
    In which directory did you unzip the folder? – hedgie May 24 at 13:09
  • @hedgie Directly on the second hard disk /dev/sda2 – AndroDev May 24 at 22:53
  • @hedgie Do you have any idea on how I could solve the problem ? Any help would be welcome – AndroDev May 25 at 23:23
  • I'm sorry, I have no idea. Your output shows plenty of free space and inodes. Maybe try becoming root? There's always a little extra space reserved for root! – hedgie May 26 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.