1

I tried to install the 64 bits Ubuntu core onto my Raspberry Pi 3B+ this morning using Raspberry Pi Imager to burn the image to the microSD card. However, after booting and all the first time configuration, I can't run apt update because apt is not there. I checked the usr/bin on the current user and root already and there's no apt on both.

The steps that I did were: 1. run the Raspberry Pi Imager, choose the SD card, choose Ubuntu 64 bits 18.04 LTS version and hit write 2. insert the microSD card into Raspberry Pi and boot it up.

These are the tutorials that I followed on the raspberry pi official website: https://www.raspberrypi.org/downloads/, https://ubuntu.com/tutorials/how-to-install-ubuntu-on-your-raspberry-pi#1-overview, https://ubuntu.com/download/raspberry-pi/thank-you?version=18.04&architecture=arm64+raspi

I have tried to reinstall using the Ubuntu raspberry pi from the Ubuntu website and burn manually without Raspberry Pi Imager and apt is still not there. I tried with the answers in these questions to manually install apt to see if it can fix the issue: apt-get removed, how to reinstall it?. However, I don't have wget or dpkg as well (I checked usr/bin).

Am I doing anything wrong? Do I need to install a specific version of Ubuntu manually or do I need to make any configuration?

p/s: I'm using a Windows PC to download and burn the image.

1

Ubuntu core 18.04 only has Snap for package management.

| improve this answer | |
  • If you want to use apt, dpkg, wget; you should use one of the preinstalled server images for raspi – Nmath Jun 4 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.