0

On Ubuntu 20.04 I installed Bluemail. Then I tried to use the Software app to install an app called "Info Center" and got "Error while installing package: installed bluemail package post-installation script subprocess returned error exit status 1".

When I ran "sudo apt-get install -f", I got:

sudo apt-get install -f

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up bluemail (1.1.14-536) ...
Installing curl...
E: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 18429 (apt-get)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
Unable to install curl!
dpkg: error processing package bluemail (--configure):
 installed bluemail package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 bluemail
E: Sub-process /usr/bin/dpkg returned an error code (1).

Bluemail is installed and working properly and I have rebooted, so I am not sure why this error is lingering around. Can someone clue me in on how to clear it?

  • I think I have resolved the issue by uninstalling Bluemail (which I had installed via .deb file from their website) and reinstalled it via Snap. Not seeing the error anymore. But I don't know why the Snap app works, but installing the .deb file didn't. – Bob Reed May 23 at 22:15
0

Because your installation terminated with status 1, indicating an error, the installation process did not complete. I can't tell why from the information you have given.

The lock file /var/lib/dpkg/lock-frontend tells Ubuntu that the graphical installation program is currently running. The file is created while installing to prevent other programs affecting the state of the computer. Usually this would be deleted when Software completes successfully, but since there was an error, the file was not removed, and apt-get thought there was still a graphical installation process running. By uninstalling Bluemail the lock file was cleared and your issue was cleared.

| improve this answer | |
  • Thank you for the clear explanation. – Bob Reed May 24 at 14:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.