-1

So, today i ran into this problem after i wanted to install a python 2.7 GUI designer. (Pygubu)

I needed the Tkinter package, so therefore i tried running

pip install tkinter.

It didnt work as it wasnt detected as a command. After that i thought i'd have to install python2 pip version (I only had python 3 with pip and python2 without pip)

I tried running this command:

sudo apt-get update && sudo apt-get install python-pip

It said that the package python-pip wasnt found, i looked into the forum to see if someone else had the problem.

As i expected, someone else had the problem, and the solution was to add some repositories.

The thing is that when i added the repositories the output said i already had them enabled.

I tried running the command again and still said that it couldnt be found.

I'd appreciate some help.


  • 2
    Which version of Ubuntu are you using? – Kulfy May 23 at 18:21
  • 1
    Please edit your question above to include the complete output of sudo apt update. – user535733 May 23 at 18:49

Browse other questions tagged or ask your own question.