0

I'm trying to get Geant4 up and running, and one of the required dependencies is to have libqt4-dev. Despite the fact that it appears in launchpad (link), I keep on getting the following error:

  • Package libqt4-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
  • E: Package 'libqt4-dev' has no installation candidate
    

I've tried sudo apt-get update and sudo apt-get upgrade, as well as following a few similar threads from 2017, but nothing has worked yet. I was able to install other libraries such as libx11-dev or libxerces-c-dev, so I don't think its a repository issue. Any ideas?

0

Doth Debian and Ubuntu have dropped QT4 from new releases, superseded by QT5.

The libqt4-dev package was dropped from Ubuntu after 19.10 and is indeed not in the 20.04 repositories. QT4 remains in older releases of Ubuntu.

If Geant4 requires obsolete/dropped software like libqt4, consider filing a bug report with the upstream developers. Alternately, you can use Ubuntu 18.04 which still has a full QT4 stack in the repositories.

| improve this answer | |
0

That's from your link, everything is said unfortunately.

Not available

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.