0

I previously used a Lenovo PC on which I have Ubuntu and Parrot installed in it. I then switched PC to HP EliteBook. To preserve state, I just switched the hard drive. When I tried booting, it didn't automatically show GRUB menu. After a day's work, I finally got it to work (I can't actually remember what I did exactly) following a tutorial using efibootmgr. Whenever I boot it, it shows:

System boot order not found initializing defaults
Creating boot entry "0007" with label "ubuntu" for file "EFI/ubuntu/shimx64.efi"

Then it shows the GRUB screen.

After a while of using my PC without any incidence I noticed that after showing the above, it had a new one:

Could not create variable, out of resource

Then it would eventually show GRUB screen.

Long story short, I did an inspection using efibootmgr -v and had the output:

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0007, 0000,0001
Boot 0000* Notebook Hard Drive BBS(HD, 0x0)
Boot 0001* Notebook upgrade Bay BBS(CDROM, 0x0)
Boot 0002* Notebook Ethernet BBS(128, 0x0)
Boot 0003* ubuntu HD(1, GPT,  2a721b0d-c3f1-4518-a3cd-764806d2691e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi
Boot 0004* ubuntu HD(1, GPT,  2a721b0d-c3f1-4518-a3cd-764806d2691e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi
Boot 0005* ubuntu HD(1, GPT,  2a721b0d-c3f1-4518-a3cd-764806d2691e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi
Boot 0006* ubuntu HD(1, GPT,  2a721b0d-c3f1-4518-a3cd-764806d2691e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi
Boot 0007* ubuntu HD(1, GPT,  2a721b0d-c3f1-4518-a3cd-764806d2691e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi

I tried deleting the duplicates of:

Boot 0003* ubuntu HD(1, GPT,  2a721b0d-c3f1-4518-a3cd-764806d2691e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi

and rebooted. It did not show:

Could not create variable, out of resource

When I inspected boot entry using efibootmgr I found out that with each boot up, a new duplicate is created automatically until there's no longer space for any new entry.

How do I: - Set Ubuntu as the default boot order. I tried using efibootmgr -o . It showed:

Could not set BootOrder: Invalid Argument
  • Ensure that my PC does not automatically create a new boot order.

Note: It is an old PC thay does not have any option for Secure Boot or a custom boot option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.