I'm trying to use the microphone from my Galaxy Buds in Ubuntu 18.04 but they don't show up in the input section.

I already tried to install blueman and change the profile to HSP/HFP but it doens't do nothing.

pacmd shows the headset_head_unit profile but it says that isn't available

index: 5
    name: <bluez_card.CC_21_19_BF_B3_1B>
    driver: <module-bluez5-device.c>
    owner module: 51
        device.description = "Galaxy Buds (B31B)"
        device.string = "CC:21:19:BF:B3:1B"
        device.api = "bluez"
        device.class = "sound"
        device.bus = "bluetooth"
        device.form_factor = "headset"
        bluez.path = "/org/bluez/hci0/dev_CC_21_19_BF_B3_1B"
        bluez.class = "0x240404"
        bluez.alias = "Galaxy Buds (B31B)"
        device.icon_name = "audio-headset-bluetooth"
        device.intended_roles = "phone"
        a2dp_sink: High Fidelity Playback (A2DP Sink) (priority 40, available: unknown)
        headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: no)
        off: Off (priority 0, available: yes)

Trying to set it anyway fails.

> pacmd set-card-profile 5 headset_head_unit
Failed to set card profile to 'headset_head_unit'.

Its the same issue reported here, but the answers gave no solution

1 Answer 1


Builded and installed pulseaudio from sources - solved this problem, microphone working ok (link to build pulseaudio from sources)
But got time to time sound distortion for some reason during playback.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .