I tend to use Ctrl+Shift+Alt for my customized system-wide keybindings.

When I tried Ctrl+Shift+Alt+U it printed an underscored u and waited for more keyboard input!...
Some keys were accepted and some were not...
eg. Numbers were accepted and they too were underlined, but only a few keys allowed me to break out.

I then tried Ctrl+Shift+Alt+U immediately followed by Ctrl+Shift+Alt+E.
This produced an unprintable hex 000E(?) and broke out of the loop...

The unprintable character got me thinking that this may be Unicode related.

If so, how so? What is happening here?
Is this underscored u a trigger for an Input Method Editor?

This behaviour occurs: Here (as I type), "gedit", text-edit fields... (but not in the Terminal)... and "gvim" reported "pattern not found"...


Ctrl-Shift-U is the short-cut to start entering a full unicode character by hand. For example, here I've typed: Ctrl-Shift-U 0 0 b 0 enter to get the degree symbol: ° which is unicode 00b0. Here is 2665, the heart: ♥

For a list of unicode symbols start here: http://en.wikipedia.org/wiki/Unicode

  • Thanks.. So the underscored u indicates the start of a Unicode codepoint(s) in hex... That means I can use my Ctrl+Shift+Alt u tripple-finger salute for my hot-key bindings :)
    – Peter.O
    Nov 10 '10 at 7:09
  • en.wikipedia.org/wiki/…
    – mchid
    Sep 27 '15 at 12:21

The glyph unicode u+240E ␎ is used when referring to u+000E aka SO (Shift Out) or ctrl-N, basically any control code is rendered as a symbol by adding 2400hex to the control code to get the equivalent unicode glyph. (aside: The wrong glyph appears in Ubuntu 12.04. It should be SO not SS. see below)

To see the different glyphs available use either the character map icon utility or one of the following terminal commands:


Consequent to this, by holding down the right button and "mousing" over the map the unicode in the bottom corner and the symbol with its defining font (if any) are displayed (circled in green for this example). In this case, for U+000E, the "character" is not printable so there is no symbol and thus no font. The other squares, highlighted in yellow for this example, are similarly unprintable because they are also control codes and associated with the characters circled in yellow. Thus ctrl-D or ^D is the same as U+0004.

To see this, open a new terminal window and instead of using the standard ^D convention to close and exit the window, simply press and hold Ctrl-Shift while typing U then 4 and then release Ctrl-Shift. Note that the leading 0's do not need to be typed.

non-printable control codes


Bad Unicode SO glyph in Ubuntu 12.04.
should be SO not SS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.