4

I recently added Terminator (terminal emulator) to my system. When I open Terminator (whether by clicking its icon in the launcher or by hitting a keyboard shortcut), a new icon appears in my launcher (Ubuntu Dock).

enter image description here

What can I do to

  1. have only a single icon and
  2. just activate the existing Terminator window if Terminator is already running?

I don't have this problem with gnome-terminal.

I'm running Ubuntu 18.04.4 LTS.

I looked at this solution for Google Chrome's icons, but it doesn't apply: my $HOME/.local/share/applications doesn't include any desktop files for Terminator.

Here's the contents of my /usr/share/applications/terminator.desktop:

[Desktop Entry]
Name=Terminator
Comment=Multiple terminals in one window
TryExec=terminator
Exec=terminator
Icon=terminator
Type=Application
Categories=GNOME;GTK;Utility;TerminalEmulator;System;
StartupNotify=true
X-Ubuntu-Gettext-Domain=terminator
X-Ayatana-Desktop-Shortcuts=NewWindow;
Keywords=terminal;shell;prompt;command;commandline;
[NewWindow Shortcut Group]
Name=Open a New Window
Exec=terminator
TargetEnvironment=Unity

Update: I've found that I can avoid some of this problem by hitting the windows key, typing 'Terminator', right-clicking 'Terminator', and selecting 'Add to favourites'. ('Add to favourites' was never an option when right-clicking the Terminator icon in the launcher itself.) However, when I hit Ctrl+Alt+t to open a terminal, it still creates a new icon in the launcher.

4
  • It's not Unity. 18.04 comes with GNOME instead of Unity by default. The screenshot, even though shows a little, suggests that it's Ubuntu Dock in GNOME (Unity Launcher has glossy backlit icons, indicator dot is also different).
    – pomsky
    May 22 '20 at 18:03
  • Thanks, @pomsky , it appears to answer my question. I'm also grateful to Richard Quint for his succinct answer below. May 22 '20 at 21:00
  • have you pinned the application terminator to your favourites in the dock?
    – Manik
    May 24 '20 at 8:13
  • @Manik, I had indeed. I experienced this issue with and without having Terminator as a favourite in my launcher. May 26 '20 at 15:36
5

Try this

Start Terminator and in the terminal run xprop WM_CLASS. Now place the cursor (probably it will look like a cross) over the Terminator window and click. Add a line to your desktop file that reads

StartupWMClass=<second entry in WM_CLASS(STRING) without the quotes>

This may solve your problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.