0

I have a new installation of Apache2 and PHP. But it seems PHP is not allowed on Apache. Server returns php as plain text. There are tons of files in /etc/apache2 directory. I dont know where to find directive to allow php. Can somebody help me please?

3
  • Please give more Details. What version of Ubuntu are you running? Did you do a regular install and then added the server programs? How did you do that? If you answer those questions people can help more. Apache2 and PHP go together very very well. – walttheboss May 22 '20 at 7:28
  • The solution is in command sudo a2enmod php7.4. There was also some problems with some npm events package which has to be disabled first by a2dismod.... – Čamo May 22 '20 at 7:32
  • Questions must not be resolved via comments. Please decide on a system-recognized resolution for this page -- either a question retraction or an accepted (educational) answer. – mickmackusa May 22 '20 at 7:35
0

Solution is to run a command sudo a2enmod php7.4. There was also some problems with npm events module which has to be disabled at first by a2dismod...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.