I have a clean 12.04 install. Imported my mp3's (from a windows share) into Rhythmbox and although they do appear to be playing no sounds is to be heard. Playing a radio-stream works just fine. Playing the same MP3 in Spotify works fine too.

I have looked at the mixer settings (but as radio is playing that does not seem to be the issue). Cannot find a reason why there is no sound...

4 Answers 4


I encountered the same problem. Go to sound settings --> applications and check if Rhythmbox is not muted.


Following the instructions here to reset Pulseaudio config solved the issue for me:

rm -fr ~/.config/pulse/ 
pulseaudio -k 

I am quite sure this is a rhythmbox bug. (Bug 977866)

Instead of reading the mp3 files directly from the share I added the share (//fileserver/music) to fstab and mounted it to /home/dries/musicshare.

When I open the same MP3 in 2 different ways, one will play without a problem, one has the described problem:

smb://fileserver/music/song.mp3 does not play /home/dries/musicshare/song.mp3 plays without a problem..

To me this is a solution, I have no problem, mounting the share directly..


I believe you will need the gstreamer plugin that should be incorporated with the ubuntu restricted extras. They are not included out of the box because of patent issues. Type in "restricted extras" in the software center and install what comes up. That should do it=) happy music

  • Thank you, Eddie but I already have those installed... (read somewhere else about gstreamer) Did notice that the first time I start music there is some noise (sounds like static or garbage) half a second long
    – Dries
    May 3, 2012 at 22:40
  • Now there is something really weird: if I open the python console before pressing play I have some music playing (but still not perfect and it does stop after about 20 seconds)
    – Dries
    May 3, 2012 at 23:09
  • I am quite sure this is a rhythmbox bug: I have mounted the share to a directory on the filesystem.. And now here's the weird thing:
    – Dries
    May 5, 2012 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.